Closed Bug 735874 Opened 9 years ago Closed 9 years ago

Add-on options should show/hide when add-on is enabled/disabled

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
normal

Tracking

(firefox13 verified, firefox14 verified)

VERIFIED FIXED
Firefox 14
Tracking Status
firefox13 --- verified
firefox14 --- verified

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

Attachments

(2 files)

Steps to reproduce:

1. Install an add-on with options.
2. Open the add-on manager and tap on the add-on.
4. Disable the add-on.

Expected results: Add-on options are hidden.
Actual results: Add-on options are still visible and enabled.

5. Quit and then re-start the browser.
6. Open the add-on manager and tap on the add-on.
7. Enable the add-on.

Expected results: Add-on options are visible.
Actual results: Add-on options are still hidden.
This patch factors out some duplicate code in the enable/disable functions.

It also fixes the code to disable the previously-active theme.  This was broken because it called "this.disable(addon)" while the disable() method does not actually take any arguments.
Attachment #605972 - Flags: review?(mark.finkle)
We can't load options for add-ons that are disabled at startup, so we need to retry when the add-on is enabled.
Attachment #605973 - Flags: review?(mark.finkle)
Comment on attachment 605972 [details] [diff] [review]
1/2: refactor enable/disable methods

Nice refactor
Attachment #605972 - Flags: review?(mark.finkle) → review+
Attachment #605973 - Flags: review?(mark.finkle) → review+
Verified/fixed on:

Aurora Fennec 13.0a2 (2012-03-27)
Nightly Fennec 14.0a1 (2012-03-27)
Device: Samsung Nexus S
OS: Android 2.3.6
Status: RESOLVED → VERIFIED
Blocks: 696533
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.