Last Comment Bug 736087 - Wifi: Rename the DOM service to not have the ns prefix
: Wifi: Rename the DOM service to not have the ns prefix
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Blake Kaplan (:mrbkap)
:
Mentors:
Depends on:
Blocks: b2g-wifi
  Show dependency treegraph
 
Reported: 2012-03-15 08:06 PDT by Blake Kaplan (:mrbkap)
Modified: 2012-03-19 12:28 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
For the DOM service (6.73 KB, patch)
2012-03-16 10:49 PDT, Blake Kaplan (:mrbkap)
philipp: review+
Details | Diff | Splinter Review
For the chrome side (7.51 KB, patch)
2012-03-16 10:50 PDT, Blake Kaplan (:mrbkap)
philipp: review+
Details | Diff | Splinter Review

Description Blake Kaplan (:mrbkap) 2012-03-15 08:06:55 PDT
See bug 732982, comment 15.
Comment 1 Blake Kaplan (:mrbkap) 2012-03-16 10:49:55 PDT
Created attachment 606632 [details] [diff] [review]
For the DOM service
Comment 2 Blake Kaplan (:mrbkap) 2012-03-16 10:50:21 PDT
Created attachment 606633 [details] [diff] [review]
For the chrome side
Comment 3 Philipp von Weitershausen [:philikon] 2012-03-16 16:05:53 PDT
Comment on attachment 606633 [details] [diff] [review]
For the chrome side

So one thing that occurred to me as well: WifiWorker and its companions should probably live in dom/system/gonk. But we can do that in a separate bug, and perhaps even while or after we consolidate some of the code in the network manager.
Comment 4 Philipp von Weitershausen [:philikon] 2012-03-16 16:23:49 PDT
Comment on attachment 606632 [details] [diff] [review]
For the DOM service

Also, as per dev-webapi discussions: the "manager" part of the DOM API is pretty useless. navigator.wifi is much nicer (because shorter) than navigator.wifiManager (modulo moz prefix). But that, too, can be a follow-up bug.
Comment 5 Blake Kaplan (:mrbkap) 2012-03-16 18:03:41 PDT
Yeah, I filed that as bug 736088.

Note You need to log in before you can comment on or make changes to this bug.