Last Comment Bug 736487 - Cleanup and ease browser_480148.js
: Cleanup and ease browser_480148.js
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Marco Bonardo [::mak]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 09:08 PDT by Marco Bonardo [::mak]
Modified: 2012-03-17 17:10 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1.0 (8.19 KB, patch)
2012-03-16 09:12 PDT, Marco Bonardo [::mak]
paul: review+
Details | Diff | Review

Description Marco Bonardo [::mak] 2012-03-16 09:08:47 PDT
The test is half sync half async, it calls all the runTest methods at once, and those end up being executed randomly at the same time, though each of those executeSoon on load.  While looking for frequent oranges, I compared 2 pgo runs, one failing and one succeeding, and this was one of the few tests behaving differently.
Since the scope of the test is quite different from opening tens of windows with tens of tabs at once and closing them at random order hoping to finish at the right time, I think it's worth to give it a path to follow.
Comment 1 Marco Bonardo [::mak] 2012-03-16 09:12:56 PDT
Created attachment 606593 [details] [diff] [review]
patch v1.0
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-03-16 10:06:24 PDT
Comment on attachment 606593 [details] [diff] [review]
patch v1.0

Review of attachment 606593 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/sessionstore/test/browser_480148.js
@@ +40,1 @@
>    requestLongerTimeout(2);

I wonder if we'll need to extend this timeout since the windows are opening sequentially. I guess we'll find out!
Comment 3 Marco Bonardo [::mak] 2012-03-16 10:10:40 PDT
Sure, that's an easy change. thanks.
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2012-03-17 17:10:39 PDT
https://hg.mozilla.org/mozilla-central/rev/06ffbf7b6518

Note You need to log in before you can comment on or make changes to this bug.