Last Comment Bug 736495 - Some scripts are importing modules with resource:///gre instead of resource:/// and vice-versa
: Some scripts are importing modules with resource:///gre instead of resource:/...
Status: RESOLVED FIXED
[qa-]
: dev-doc-needed
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 09:25 PDT by Mike Hommey [:glandium]
Modified: 2012-05-10 12:17 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Some scripts are importing modules with resource:///gre instead of resource:/// and vice-versa (3.97 KB, patch)
2012-03-16 09:32 PDT, Mike Hommey [:glandium]
gavin.sharp: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-03-16 09:25:19 PDT

    
Comment 1 Mike Hommey [:glandium] 2012-03-16 09:32:18 PDT
Created attachment 606601 [details] [diff] [review]
Some scripts are importing modules with resource:///gre instead of resource:/// and vice-versa
Comment 3 Mike Hommey [:glandium] 2012-03-19 00:32:38 PDT
Comment on attachment 606601 [details] [diff] [review]
Some scripts are importing modules with resource:///gre instead of resource:/// and vice-versa

[Approval Request Comment]
Regression caused by various bugs: 
User impact if declined: Firefox-on-xulrunner setups have some features broken
Risk to taking this patch (and alternatives if risky): On mozilla builds, resource:/// and resource://gre/ are strictly equivalent (which is why such bugs happen in the first place), so for mozilla builds, this is effectively a noop.
String changes made by this patch: none.
Comment 4 Matt Brubeck (:mbrubeck) 2012-03-19 10:21:56 PDT
https://hg.mozilla.org/mozilla-central/rev/4a8e46ce88dd
Comment 5 Mike Hommey [:glandium] 2012-03-20 00:16:40 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/5e80b801b695

Note You need to log in before you can comment on or make changes to this bug.