jssubloader files are not packaged properly

RESOLVED FIXED in Firefox 13

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla14
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox11 unaffected, firefox12 unaffected, firefox13 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Bug 648125 added support for cache for js loaded with loadSubScript. Somehow (probably because so many scripts just fail in the xpcshell harness used to generate jsloader cache), it was never exercised until bug 697762 landed.

Now, there is a jssubloader/185/resource/gre/chrome/toolkit/content/global/devtools/dbg-transport.js that ends up packaged. That file should obviously be in omni.jar.
(Assignee)

Updated

5 years ago
Blocks: 697762, 648125
(Assignee)

Updated

5 years ago
status-firefox11: --- → unaffected
status-firefox12: --- → unaffected
status-firefox13: --- → affected
Do you want to dupe bug 732649 to this or vice versa?
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732649
(Assignee)

Comment 3

5 years ago
Created attachment 606639 [details] [diff] [review]
Package jssubloader cache in omnijar
Attachment #606639 - Flags: review?(khuey)
Attachment #606639 - Flags: review?(khuey) → review+
(Assignee)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

5 years ago
Duplicate of this bug: 732649
(Assignee)

Updated

5 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/68def3ab33b6

Comment 6

5 years ago
Please can you set the target milestone when landing on inbound, along the lines of http://blog.bonardo.net/2012/03/23/how-you-can-help-mozilla-inbound-sheriffs-when-pushing :-)

https://hg.mozilla.org/mozilla-central/rev/68def3ab33b6
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
(Assignee)

Comment 7

5 years ago
Comment on attachment 606639 [details] [diff] [review]
Package jssubloader cache in omnijar

[Approval Request Comment]
Regression caused by combination of bug 648125 and bug 697762
User impact if declined: extra unused file shipped in tarballs/installers
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Attachment #606639 - Flags: approval-mozilla-aurora?

Comment 8

5 years ago
Comment on attachment 606639 [details] [diff] [review]
Package jssubloader cache in omnijar

[Triage Comment]
Doesn't sound like this is absolutely necessary from the user's perspective, but given where we are in Aurora this should be OK to land.
Attachment #606639 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
Created attachment 609641 [details] [diff] [review]
Add jssubloader to removed-files
Attachment #609641 - Flags: review?(khuey)
Attachment #609641 - Flags: review?(khuey) → review+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a5a55d435ca
(Assignee)

Comment 11

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/2ee0ace363aa
status-firefox13: affected → fixed
(In reply to Mike Hommey [:glandium] from comment #10)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/5a5a55d435ca

https://hg.mozilla.org/mozilla-central/rev/5a5a55d435ca
Blocks: 741215
You need to log in before you can comment on or make changes to this bug.