Last Comment Bug 736655 - [10.8] Mac dmg installer dialog doesn't look right
: [10.8] Mac dmg installer dialog doesn't look right
Status: RESOLVED FIXED
[qa+]
:
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Steven Michaud [:smichaud] (Retired)
:
: Matt Howell [:mhowell]
Mentors:
Depends on:
Blocks: mountain-lion-compat
  Show dependency treegraph
 
Reported: 2012-03-16 17:04 PDT by Marcia Knous [:marcia - use ni]
Modified: 2012-06-15 07:24 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified


Attachments
Screenshot of Beta dialog (168.03 KB, image/png)
2012-03-16 17:04 PDT, Marcia Knous [:marcia - use ni]
no flags Details
"Official" background.png resized for Mountain Lion (110.61 KB, image/png)
2012-05-23 15:46 PDT, Steven Michaud [:smichaud] (Retired)
no flags Details
Aurora background.png resized for Mountain Lion (101.79 KB, image/png)
2012-05-23 15:58 PDT, Steven Michaud [:smichaud] (Retired)
no flags Details
Nightly background.png resized for Mountain Lion (96.41 KB, image/png)
2012-05-23 15:59 PDT, Steven Michaud [:smichaud] (Retired)
no flags Details
Resize background.png files to fit Mountain Lion dmg window's minimum size (398.68 KB, patch)
2012-05-23 18:59 PDT, Steven Michaud [:smichaud] (Retired)
gavin.sharp: review+
shorlander: ui‑review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review
screenshot (161.31 KB, image/png)
2012-05-30 06:01 PDT, Vlad [QA]
no flags Details
screenshot (184.60 KB, image/png)
2012-06-15 00:52 PDT, Vlad [QA]
no flags Details

Description Marcia Knous [:marcia - use ni] 2012-03-16 17:04:31 PDT
Created attachment 606793 [details]
Screenshot of Beta dialog

Apple just released a new seed today, 12A154q. I noticed when downloading the beta that the dialog doesn't look quite right. Attaching a few screenshots.
Comment 1 Marcia Knous [:marcia - use ni] 2012-03-16 17:07:11 PDT
Checked Aurora and Nightly and the same thing happens.
Comment 2 Marcia Knous [:marcia - use ni] 2012-05-10 12:58:14 PDT
Now that there is a new Dev Preview I will check this again.
Comment 3 Marcia Knous [:marcia - use ni] 2012-05-15 10:43:42 PDT
Still happening in the latest Dev Preview, Build ID 12A193i when downloading the latest Firefox beta build.
Comment 4 Steven Michaud [:smichaud] (Retired) 2012-05-17 16:00:08 PDT
This looks really bad.  I'll see if I can fix it next week.
Comment 5 Steven Michaud [:smichaud] (Retired) 2012-05-23 14:06:27 PDT
What causes this bug is that the minimum size for a "folder window"
has changed (increased) on OS X 10.8, so that it's now wider than the
background image used by our dmg installer's "folder window" (the
window that opens when you double-click on the dmg installer).

I'd hoped to force the window to display at a smaller than minimum
width.  And I actually accomplished this ... but the effect wasn't
permanent.

So it now looks like the only way to fix this bug is to increase the
width of the background image.

For the record, here's what I did:

1) Created and mounted a read-write DMG corresponding to FF 12's dmg:

   a) hdiutil convert "Firefox 12.0.dmg" -format UDRW -o stage1.dmg
   b) hdiutil resize -size 150m stage1.dmg
   c) hdiutil attach stage1.dmg -readwrite -autoopen

2) Ran the following AppleScript to correct the dmg folder window's
   size:

   tell application "Finder"
   tell window 1
       set current view to icon view
       set toolbar visible to false
       set bounds to {362, 95, 778, 390}
   end tell
   end tell

   Running this script changed the /Volumes/Firefox/.DS_Store file,
   and *might* have stored the new size and location information.  But
   you'll see in step 4 that this didn't help.

3) Detached the altered stage1.dmg and converted it back to readonly
   format:

   d) hdiutil detach /dev/disk1
   e) hdiutil convert stage1.dmg -format UDBZ -o stage2.dmg

4) Mounted stage2.dmg and observed that its folder window was too wide
   -- that it's width was the new Mountain Lion minimum width, and not
   the smaller width that I'd (presumably) caused to be written to
   .DS_Store in step 2.
Comment 6 Steven Michaud [:smichaud] (Retired) 2012-05-23 14:20:48 PDT
>   tell application "Finder"
>   tell window 1
>       set current view to icon view
>       set toolbar visible to false
>       set bounds to {362, 95, 778, 390}
>   end tell
>   end tell

I cut this down as follows and tried again.  Still no luck.

   tell application "Finder"
   tell window 1
       set bounds to {362, 95, 778, 390}
   end tell
   end tell
Comment 7 Steven Michaud [:smichaud] (Retired) 2012-05-23 14:46:48 PDT
Alex, it looks like you created the original background.png artwork for FF releases, way back in bug 320155.

Any chance you could widen it?

The same thing also needs to be done for the background.png artwork for Aurora and Nightly.  The files that need to be changed are here:

browser/branding/aurora/background.png
browser/branding/nightly/background.png
browser/branding/official/background.png

I'll get you an exact number of pixels that they need to be widened.  I suspect (but am still not sure) that the images need to be widened by half that number of pixels on each side.
Comment 8 Steven Michaud [:smichaud] (Retired) 2012-05-23 15:06:29 PDT
The "original" (and incorrect) bounds of the FF release dmg's folder window on OS X 10.8 are {362, 95, 799, 390}.

I got this by running the following AppleScript:

   tell application "Finder"
   tell window 1
       get bounds
   end tell
   end tell

The bounds of the correctly sized folder window (correctly sized by trial and error for the current background.png artwork) are:

{362, 95, 778, 390}

That's a difference of 21 pixels.  Awkward that it's an odd number.
Comment 9 Steven Michaud [:smichaud] (Retired) 2012-05-23 15:46:17 PDT
Created attachment 626609 [details]
"Official" background.png resized for Mountain Lion

Maybe this isn't as difficult as I first thought.

Here's a copy of the "official" background.png that I resized in Photoshop (CS5).  I added 22 pixels to the width, and told Photoshop to change the height proportionally.

I've tried it in an altered FF 12 dmg on Moutain Lion and it looks fine ... at least to me.  I'll also try it on other versions of OS X.

Alex Faaborg, let us know if you'd be willing to let us use this resized image.  Shortly I'll attach resized copies of the aurora and nightly background.png files.
Comment 10 Steven Michaud [:smichaud] (Retired) 2012-05-23 15:58:00 PDT
Created attachment 626615 [details]
Aurora background.png resized for Mountain Lion
Comment 11 Steven Michaud [:smichaud] (Retired) 2012-05-23 15:59:04 PDT
Created attachment 626618 [details]
Nightly background.png resized for Mountain Lion
Comment 12 Steven Michaud [:smichaud] (Retired) 2012-05-23 16:32:43 PDT
Here's a copy of the altered FF 12 dmg package that I've been testing with (which contains my resized "official" background.png):

https://people.mozilla.com/~stmichaud/ResizedBackground/Firefox%2012.0-resized-background.dmg

It looks fine (to me) on OS X 10.5.8, 10.6.8, 10.7.4 and 10.8.
Comment 13 Alex Keybl [:akeybl] 2012-05-23 18:10:09 PDT
(In reply to Steven Michaud from comment #12)
> Here's a copy of the altered FF 12 dmg package that I've been testing with
> (which contains my resized "official" background.png):
> 
> https://people.mozilla.com/~stmichaud/ResizedBackground/Firefox%2012.0-
> resized-background.dmg
> 
> It looks fine (to me) on OS X 10.5.8, 10.6.8, 10.7.4 and 10.8.

Looks good to me on 10.7 as well. Tracking for FF13 (although this is not a blocker). If Steven agrees, this can make it into our final beta, going to build on Monday.
Comment 14 Steven Michaud [:smichaud] (Retired) 2012-05-23 18:59:06 PDT
Created attachment 626668 [details] [diff] [review]
Resize background.png files to fit Mountain Lion dmg window's minimum size

Gavin, you reviewed my last patch that changed the appearance of our dmg package's window.  Could you review this one, too?

If you'd rather someone else do the review, please pass it along.

I've replaced the existing background.png files in the following directories with the resized copies that I've attached here.  I resized them in Photoshop (CS5), and had Photoshop increase the width by 22 pixels and the height proportionally.

In my tests they now look fine on all supported (and soon to be supported) versions of OS X (10.5.8 through 10.8).
Comment 15 Steven Michaud [:smichaud] (Retired) 2012-05-23 19:01:09 PDT
> Gavin, you reviewed my last patch that changed the appearance of our dmg package's
> window.

That was bug 714951.
Comment 16 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-05-23 19:10:59 PDT
Comment on attachment 626668 [details] [diff] [review]
Resize background.png files to fit Mountain Lion dmg window's minimum size

thanks!
Comment 17 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-05-23 19:12:41 PDT
Comment on attachment 626668 [details] [diff] [review]
Resize background.png files to fit Mountain Lion dmg window's minimum size

Though maybe shorlander (or martell, who IIRC created these originally?) might want to generate new images that aren't rescaled.
Comment 18 Steven Michaud [:smichaud] (Retired) 2012-05-24 11:13:50 PDT
Comment on attachment 626668 [details] [diff] [review]
Resize background.png files to fit Mountain Lion dmg window's minimum size

Landed on mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/8990746591f9

I'd like to get this into FF 13, which makes it very urgent.  So I've landed it on the trunk on the strength of Gavin's r+.  If shorlander or martell think we need to change these images again, we can address that in a new bug.
Comment 19 Stephen Horlander [:shorlander] 2012-05-24 11:18:24 PDT
Comment on attachment 626668 [details] [diff] [review]
Resize background.png files to fit Mountain Lion dmg window's minimum size

Review of attachment 626668 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Steven Michaud from comment #18)
> I'd like to get this into FF 13, which makes it very urgent.  So I've landed
> it on the trunk on the strength of Gavin's r+.  If shorlander or martell
> think we need to change these images again, we can address that in a new bug.

Works for me. I will talk to martell to track down the files for the background images.
Comment 20 Steven Michaud [:smichaud] (Retired) 2012-05-24 12:24:05 PDT
Comment on attachment 626668 [details] [diff] [review]
Resize background.png files to fit Mountain Lion dmg window's minimum size

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
na
User impact if declined: 
The dmg package's window will look broken on OS X 10.8 (Mountain Lion)
Testing completed (on m-c, etc.): 
One successful set of tryserver builds, ongoing trunk build (successful so far)
Risk to taking this patch (and alternatives if risky): 
Small risk of visual glitches in dmg package window, but none seen so far on any version of OS X.
String or UUID changes made by this patch: 
none
Comment 21 Alex Keybl [:akeybl] 2012-05-24 15:39:30 PDT
Comment on attachment 626668 [details] [diff] [review]
Resize background.png files to fit Mountain Lion dmg window's minimum size

[Triage Comment]
Thanks for getting this together in time for our final beta Monday. Approved for all branches.
Comment 22 Steven Michaud [:smichaud] (Retired) 2012-05-24 17:43:49 PDT
Comment on attachment 626668 [details] [diff] [review]
Resize background.png files to fit Mountain Lion dmg window's minimum size

Landed on aurora:
http://hg.mozilla.org/releases/mozilla-aurora/rev/6db75fba7c00

Landed on beta:
http://hg.mozilla.org/releases/mozilla-beta/rev/cecfcccccd9d
Comment 23 Vlad [QA] 2012-05-30 06:01:37 PDT
Created attachment 628317 [details]
screenshot

I've tested this on Mac 10.8 and as you can see from the attachment, there still are white borders on the sides.
Comment 24 Steven Michaud [:smichaud] (Retired) 2012-05-30 08:11:48 PDT
What did you test?  I didn't see this with the build1 RC of FF 13.0b6, which I tested with on OS X 10.8 yesterday.
Comment 25 Vlad [QA] 2012-05-31 02:05:21 PDT
That's strange, today with the same build, FF 13b6, everything looks fine.
Only one narrow white vertical line remains on the left side.
Except from this, everything is looking ok.

Considering this, I'm changing the flag to verified on Firefox 13 beta 6 on MacOS X 10.8.

(In reply to Steven Michaud from comment #24)
> What did you test?  I didn't see this with the build1 RC of FF 13.0b6, which
> I tested with on OS X 10.8 yesterday.
Comment 26 Vlad [QA] 2012-06-12 01:16:05 PDT
I've retested the dialog on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:14.0) Gecko/20100101 Firefox/14.0 beta 6 (build2)

and it's looking as expected, without the white borders.

Setting the flag to Verified.
Comment 27 Vlad [QA] 2012-06-15 00:52:01 PDT
Created attachment 633425 [details]
screenshot

I've retested this on other test machine with MacOS X 10.8 and it seems that the issue isn't gone.
The tests were made on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:13.0) Gecko/20100101 Firefox/13.0.1 and also on Firefox 13 and 14beta7 with the same results as in the attachament.
Comment 28 Steven Michaud [:smichaud] (Retired) 2012-06-15 07:24:29 PDT
(In reply to comment #27)

I'll bet you also had mounted the dmg of an earlier version of Firefox (one without this patch).  Or that you'd recently had it mounted.

I myself saw this once.  I think it's an Apple bug.

Note You need to log in before you can comment on or make changes to this bug.