Closed Bug 736666 Opened 8 years ago Closed 6 years ago

Crash in glDrawArrays on the Samsung Galaxy Nexus at startup

Categories

(Firefox for Android :: General, defect, critical)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: martijn.martijn, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash][gfx][startupcrash])

Crash Data

Sorry, I don't have steps to reproduce, but I have gotten this crash now a couple of times. I didn't visit any webgl sites in these Fennec sessions, when this crash happened.
The crashes happen after opening Fennec again after it was in the background for a while.

I had this page at least open: http://people.mozilla.org/~mwargers/tests/plugins/flash/flashembed.html
And the Flash plugins were activated.

https://crash-stats.mozilla.com/report/index/bp-8a116881-761f-496d-8a04-a87c32120317
0 	libc.so 	libc.so@0xdb78 	
1 	libGLESv2_POWERVR_SGX540_120.so 	libGLESv2_POWERVR_SGX540_120.so@0xb72a 	
2 	libGLESv2_POWERVR_SGX540_120.so 	libGLESv2_POWERVR_SGX540_120.so@0xd8e2 	
3 	libGLESv2_POWERVR_SGX540_120.so 	libGLESv2_POWERVR_SGX540_120.so@0x5a38e 	
4 	libGLESv2_POWERVR_SGX540_120.so 	libGLESv2_POWERVR_SGX540_120.so@0xea4e 	
5 	libandroid_runtime.so 	libandroid_runtime.so@0x4e0c1 	
6 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x78156 	
7 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x7620e 	
8 	libandroid_runtime.so 	libandroid_runtime.so@0x4e583 	
9 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x7620e 	
10 	libdvm.so 	libdvm.so@0x1ec72 	
11 	libdvm.so 	libdvm.so@0x544d7 	
12 	dalvik-heap (deleted) 	dalvik-heap @0x45996 	
13 	libdvm.so 	libdvm.so@0x5906b 	
14 	framework.odex 	framework.odex@0x6487c2 	
15 	libandroid_runtime.so 	libandroid_runtime.so@0x4e577 	
16 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x5ed55e 	
17 	dalvik-heap (deleted) 	dalvik-heap @0x45996 	
18 	libdvm.so 	libdvm.so@0xb7c56 	
19 	dalvik-heap (deleted) 	dalvik-heap @0x49c4e 	
20 	libdvm.so 	libdvm.so@0xb2f8e
libGLESv2_POWERVR_SGX540_120.so@0xea4e is glDrawArrays.

Since this is happening after being in the background, it could be related to Bug 735230.

On the other hand, since this involves Flash, it could be an entirely separate issue.
Summary: Crash [@ ] on the Samsung Galaxy Nexus after reopening Fennec after being in the background for a while → Crash [@ ] on the Samsung Galaxy Nexus after reopening Fennec after being in the background for a while on a page with Flash
Crash Signature: [@ libGLESv2_POWERVR_SGX540_120.so@0xb72a ]
Summary: Crash [@ ] on the Samsung Galaxy Nexus after reopening Fennec after being in the background for a while on a page with Flash → Crash in glDrawArrays on the Samsung Galaxy Nexus after reopening Fennec after being in the background for a while on a page with Flash
Whiteboard: [native-crash]
Version: Trunk → Firefox 14
Whiteboard: [native-crash] → [native-crash][gfx]
Depends on: 735230
ajuma, I'm just assigning this bug to you because related bug 735230 is also assigned to you.
Assignee: nobody → ajuma
Whiteboard: [native-crash][gfx] → [native-crash][gfx][startupcrash]
I just saw this crash again with this page loaded http://www.toufee.com/demo/create-flash.html and Fennec in the background. That page is a Flash demo page.
Ok, I just crashed now, without having any Flash page opened in the background.
blocking-fennec1.0: --- → ?
I'm hitting this crash a lot. My hunch is that it has something to do with EGLContext changing.
Summary: Crash in glDrawArrays on the Samsung Galaxy Nexus after reopening Fennec after being in the background for a while on a page with Flash → Crash in glDrawArrays on the Samsung Galaxy Nexus after reopening Fennec after being in the background for a while
blocking-fennec1.0: ? → beta+
This crash is Fennec 14's #3 topcrash.
Of the 78 crashes with this signature over the past 7 days, 77 are on builds from March 23rd and earlier, and 1 is on the March 25th build.
Since we don't have crashes on builds newer than March 25th, let's close this for now. Please reopen if this crashes on a newer build.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
It occurs in 15.0a1/20120525 and 14.0b2: https://crash-stats.mozilla.com/report/list?signature=libGLESv2_POWERVR_SGX540_120.so%400xb72a
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The crashes occurring now are all at startup.
Summary: Crash in glDrawArrays on the Samsung Galaxy Nexus after reopening Fennec after being in the background for a while → Crash in glDrawArrays on the Samsung Galaxy Nexus at startup
Re-nomming since this is now only the 225-th top crash in 14.0b2 (accounting for 0.05% of all crashes there), so it doesn't seem like a hard blocker anymore.
blocking-fennec1.0: beta+ → ?
Keywords: topcrash
blocking-fennec1.0: ? → -
Assignee: ajuma.bugzilla → nobody
I haven't seen this for a while.
Status: REOPENED → RESOLVED
Closed: 8 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.