Last Comment Bug 736689 - Disable tearing on OS X
: Disable tearing on OS X
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: Jeff Muizelaar [:jrmuizel]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 19:35 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-04-29 11:06 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Disable tearing (921 bytes, patch)
2012-03-16 19:35 PDT, Jeff Muizelaar [:jrmuizel]
roc: review+
joe: approval‑mozilla‑central+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-03-16 19:35:46 PDT
Created attachment 606826 [details] [diff] [review]
Disable tearing

We tear much worse than all other browser on OS X. This patch fixes it. I'm told this change was originally done for performance, but it doesn't seem to make much difference anymore: http://tinyurl.com/7ay3jzo. I expect because we no longer paint very much to the window context, we no longer see the improvement this used to bring.
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-04-10 20:40:54 PDT
Comment on attachment 606826 [details] [diff] [review]
Disable tearing

Review of attachment 606826 [details] [diff] [review]:
-----------------------------------------------------------------

I expect that the "all painting should go through the refresh driver" patches have helped make this unnecessary.

Please watch out for reports of Mac performance regressions though.
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-04-20 16:09:39 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/47da536b5144
Comment 3 Phil Ringnalda (:philor) 2012-04-21 23:54:56 PDT
https://hg.mozilla.org/mozilla-central/rev/47da536b5144
Comment 4 :Ehsan Akhgari 2012-04-22 12:32:01 PDT
For the record:

Improvement! DHTML 2 MozAfterPaint decrease 6.66% on MacOSX 10.6 (rev4) Mozilla-Inbound
---------------------------------------------------------------------------------------
   Previous: avg 345.945 stddev 1.930 of 30 runs up to revision bce6cabacc88
   New     : avg 322.888 stddev 1.167 of 5 runs since revision 47da536b5144
   Change  : -23.057 (6.66% / z=11.945)
   Graph   : http://mzl.la/J7DcHN

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bce6cabacc88&tochange=47da536b5144

Changesets:
 * http://hg.mozilla.org/integration/mozilla-inbound/rev/47da536b5144
   : Jeff Muizelaar <jmuizelaar@mozilla.com> - Bug 736689. Disable tearing on OS X. r=roc, a=joe

We tear much worse than all other browser on OS X. I'm told this change was
originally done for performance, but it doesn't seem to make much difference
anymore: http://tinyurl.com/7ay3jzo. I expect because we no longer paint very
much to the window context, we no longer see the improvement this used to
bring. In addition, the refresh driver already coalesces paints.
   : http://bugzilla.mozilla.org/show_bug.cgi?id=736689

Bugs:
 * http://bugzilla.mozilla.org/show_bug.cgi?id=736689
Comment 5 Joe Drew (not getting mail) 2012-04-23 15:24:59 PDT
That astonishes me!
Comment 6 Jeff Muizelaar [:jrmuizel] 2012-04-23 15:31:02 PDT
FWIW, we still tear :(

Note You need to log in before you can comment on or make changes to this bug.