Last Comment Bug 736696 - "87984 (3812d0ce274e) Merge last green changeset from inbound to mozilla-central" went wrong
: "87984 (3812d0ce274e) Merge last green changeset from inbound to mozilla-cent...
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: All All
: P2 major (vote)
: mozilla14
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: 629595 735805
  Show dependency treegraph
 
Reported: 2012-03-16 20:50 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-03-27 09:43 PDT (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (3.23 KB, patch)
2012-03-20 10:23 PDT, Matt Brubeck (:mbrubeck)
bugzillamozillaorg_serge_20140323: feedback+
Details | Diff | Review

Description Serge Gautherie (:sgautherie) 2012-03-16 20:50:07 PDT
I noticed
http://hg.mozilla.org/mozilla-central/diff/3812d0ce274e/content/canvas/test/webgl/test_webgl_conformance_test_suite.html
should not have happened at all: m-c code was newer!

Please back this (whole) merge out asap.

NB: And probably need to do an history check on all these merges...
Comment 1 Matt Brubeck (:mbrubeck) 2012-03-20 10:23:48 PDT
Created attachment 607612 [details] [diff] [review]
patch

Sorry!  I'm guessing maybe the merge got confused because these changes landed on central:
https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=023130d28f50
https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=cb01e23f83cf

while one of the same changes landed and was backed out on inbound:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=6a94d3142674
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=f6d04ce89a9e

Here's a patch to back out the changes made to this test_webgl_conformance_test_suite.html in the merge.  (This was the only file that had conflicts in this merge.)

Note:  If everyone making changes to a single file can coordinate and land those changes in a single tree, it will completely avoid any conflicts or merges problems like this.
Comment 2 Serge Gautherie (:sgautherie) 2012-03-25 21:52:23 PDT
Comment on attachment 607612 [details] [diff] [review]
patch

(In reply to Matt Brubeck (:mbrubeck) from comment #1)

> Here's a patch to back out the changes made to this
> test_webgl_conformance_test_suite.html in the merge.  (This was the only
> file that had conflicts in this merge.)

Thanks!
Note you now need to back out
http://hg.mozilla.org/mozilla-central/diff/c56fbf96661b/content/canvas/test/webgl/test_webgl_conformance_test_suite.html
which happened in the meantime, first.

> Note:  If everyone making changes to a single file can coordinate and land
> those changes in a single tree, it will completely avoid any conflicts or
> merges problems like this.

I don't think that's realistic.
Yet, in this occurrence, note that I never asked for that inbound landing.
Comment 4 Marco Bonardo [::mak] 2012-03-27 05:23:26 PDT
https://hg.mozilla.org/mozilla-central/rev/22065301995a
Comment 5 Serge Gautherie (:sgautherie) 2012-03-27 09:43:05 PDT
V.Fixed, per MXR.

Note You need to log in before you can comment on or make changes to this bug.