Last Comment Bug 736707 - B2G SMS: Support type-0 message
: B2G SMS: Support type-0 message
Status: RESOLVED FIXED
[good first bug][lang=js]
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla14
Assigned To: Vicamo Yang [:vicamo][:vyang]
:
Mentors:
Depends on: 736697
Blocks: b2g-sms 736706 736710
  Show dependency treegraph
 
Reported: 2012-03-16 23:54 PDT by Vicamo Yang [:vicamo][:vyang]
Modified: 2012-04-09 10:16 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Support Type-0 Message (1001 bytes, patch)
2012-03-20 02:25 PDT, Vicamo Yang [:vicamo][:vyang]
no flags Details | Diff | Splinter Review
Support Type-0 Message : V2 (1.04 KB, patch)
2012-03-26 02:33 PDT, Vicamo Yang [:vicamo][:vyang]
no flags Details | Diff | Splinter Review
Part 1: TP-PID sanity checks (4.95 KB, patch)
2012-03-27 06:26 PDT, Vicamo Yang [:vicamo][:vyang]
no flags Details | Diff | Splinter Review
Part 2: Support Type-0 Message : V3 (1.82 KB, patch)
2012-03-27 06:31 PDT, Vicamo Yang [:vicamo][:vyang]
no flags Details | Diff | Splinter Review
Part 1: TP-PID sanity checks : V2 (4.97 KB, patch)
2012-03-28 06:07 PDT, Vicamo Yang [:vicamo][:vyang]
no flags Details | Diff | Splinter Review
Part 1: TP-PID sanity checks : V3 (4.99 KB, patch)
2012-03-28 23:12 PDT, Vicamo Yang [:vicamo][:vyang]
no flags Details | Diff | Splinter Review
Part 2: Support Type-0 Message : V4 (1.84 KB, patch)
2012-03-28 23:13 PDT, Vicamo Yang [:vicamo][:vyang]
philipp: review+
Details | Diff | Splinter Review
Part 1: TP-PID sanity checks : V4 (5.00 KB, patch)
2012-03-29 01:00 PDT, Vicamo Yang [:vicamo][:vyang]
philipp: review+
Details | Diff | Splinter Review
Part 1: TP-PID sanity checks : V5 (4.86 KB, patch)
2012-04-05 21:04 PDT, Vicamo Yang [:vicamo][:vyang]
philipp: review+
Details | Diff | Splinter Review
Part 2: Support Type-0 Message : V5 (1.88 KB, patch)
2012-04-05 21:05 PDT, Vicamo Yang [:vicamo][:vyang]
philipp: review+
Details | Diff | Splinter Review

Description Vicamo Yang [:vicamo][:vyang] 2012-03-16 23:54:35 PDT
According to 3GPP 23.040 section 9.2.3.9, "A short message type 0 indicates that the ME must acknowledge receipt of the short message but shall discard its contents."
Comment 1 Vicamo Yang [:vicamo][:vyang] 2012-03-17 09:31:43 PDT
There are also three levels of "don't store" throughout the spec and might have to be taken into consideration together. They are:

1) TP-PID: the whole message should be discarded without further handling.
2) DCS MWI(Message Waiting Indication): message should be read and discard after notifying the indication and/or displaying the message content. See bug 736710.
3) In user data header Enhanced Voice Mail Information. See bug 736710.

We should focus on 1) in this issue and provide a way that can be reused in related tasks.
Comment 2 Vicamo Yang [:vicamo][:vyang] 2012-03-20 02:25:28 PDT
Created attachment 607491 [details] [diff] [review]
Support Type-0 Message

This change is based on bug 736697, Part 2: Refactor to share methods.
Comment 3 Vicamo Yang [:vicamo][:vyang] 2012-03-20 03:22:08 PDT
verified with rev 9ff494dfc9b0 ;)
Comment 4 Vicamo Yang [:vicamo][:vyang] 2012-03-26 02:33:30 PDT
Created attachment 609262 [details] [diff] [review]
Support Type-0 Message : V2

1) rebase due to changes in attachment #609252 [details] [diff] [review]
2) now based on bug 736697 part 5
Comment 5 Vicamo Yang [:vicamo][:vyang] 2012-03-27 06:26:39 PDT
Created attachment 609695 [details] [diff] [review]
Part 1: TP-PID sanity checks
Comment 6 Vicamo Yang [:vicamo][:vyang] 2012-03-27 06:31:21 PDT
Created attachment 609696 [details] [diff] [review]
Part 2: Support Type-0 Message : V3

rebase due to changes in attachment 609634 [details] [diff] [review] in bug 736697
Comment 7 Vicamo Yang [:vicamo][:vyang] 2012-03-28 06:07:51 PDT
Created attachment 610100 [details] [diff] [review]
Part 1: TP-PID sanity checks : V2

accommodate to changes made in bug 736697 attachment 610085 [details] [diff] [review]
Comment 8 Vicamo Yang [:vicamo][:vyang] 2012-03-28 23:12:54 PDT
Created attachment 610450 [details] [diff] [review]
Part 1: TP-PID sanity checks : V3

upate comments
Comment 9 Vicamo Yang [:vicamo][:vyang] 2012-03-28 23:13:32 PDT
Created attachment 610451 [details] [diff] [review]
Part 2: Support Type-0 Message : V4

update comments
Comment 10 Vicamo Yang [:vicamo][:vyang] 2012-03-29 01:00:53 PDT
Created attachment 610477 [details] [diff] [review]
Part 1: TP-PID sanity checks : V4

missing comma
Comment 11 Philipp von Weitershausen [:philikon] 2012-04-05 13:57:58 PDT
Comment on attachment 610477 [details] [diff] [review]
Part 1: TP-PID sanity checks : V4

Review of attachment 610477 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/system/gonk/ril_worker.js
@@ +3035,5 @@
> +   *
> +   * @return read pid and effective pid.
> +   *
> +   * @see 3GPP TS 23.040 9.2.3.9
> +   */

Instead of an array return value, could this method simply take the msg object and set msg.epid, msg.pid? I think I would prefer that.

r=me with that, unless there's a good reason not do this.
Comment 12 Vicamo Yang [:vicamo][:vyang] 2012-04-05 21:04:50 PDT
Created attachment 612790 [details] [diff] [review]
Part 1: TP-PID sanity checks : V5

review comment 11
Comment 13 Vicamo Yang [:vicamo][:vyang] 2012-04-05 21:05:35 PDT
Created attachment 612791 [details] [diff] [review]
Part 2: Support Type-0 Message : V5

review comment 11
Comment 14 Vicamo Yang [:vicamo][:vyang] 2012-04-05 21:06:51 PDT
(In reply to Philipp von Weitershausen [:philikon] from comment #11)
> Instead of an array return value, could this method simply take the msg
> object and set msg.epid, msg.pid? I think I would prefer that.
> 
> r=me with that, unless there's a good reason not do this.

I agree. That simplifies the patches. Thanks.

Note You need to log in before you can comment on or make changes to this bug.