Closed Bug 73671 Opened 19 years ago Closed 18 years ago

[XUL Syntax] Replace <box> with <hbox> and <box orient|align="vertical"> with <vbox>

Categories

(Core :: XUL, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla0.9.3

People

(Reporter: hyatt, Assigned: hamfastgamgee)

References

Details

(Whiteboard: [XUL1.0])

This bug should improve performance a bit, since we'll cut down on the # of 
attributes in our content model.  This change should be made in both the XUL 
and in the XBL.
Blocks: 70753
Status: NEW → ASSIGNED
Whiteboard: [XUL1.0]
Target Milestone: --- → mozilla1.0
*** Bug 70857 has been marked as a duplicate of this bug. ***
What happens to <box orient="vertical" autostretch="never" valign="bottom">?

I can't see any CSS that would style a vbox in the same way.
box-pack and box-align will handle the autostretch/valign stuff.  Those are
other bugs.  This bug just covers turning <box orient="vertical"> into <vbox>
while leaving all other attributes alone.
Taking.

<box/> is completely defunct correct?

As to css, should box selectors be changed to just hbox, or should I create a
rule that allows for either orientation?  (box[orient=whatever] is self
explanatory obviously)
Assignee: hyatt → maolson
Status: ASSIGNED → NEW
I'm more concerned with fixing <box orient="vertical"> to be <vbox>.  YOu don't 
have to eliminate every last <box> unless you're feeling really motivated.

This bug really falls in the category of cleanup rather than syntax changes, 
since I don't plan to deprecate or obsolete the <box> tag or the orient 
attribute.
I've got a tool I've written in the last two days that will brute-force this 
conversion for the entire tree.  I'd be more than willing to take charge of this 
bug, since I can just roll it into the patch that I'm working on in bug 70857 
(that also fixes two other bugs that are in Bugzilla and a couple of bugs that 
aren't :) ), and I can get the conversion done in about ten minutes (all of 
which is spent just running the .exe).  Since the change I'm making is going to 
require a carpool at the beginning of 0.9.3 (at the earliest) anyway, shall I 
take this one, too?
I've got a patch for this in bug 70857 that I'm trying to get in at the start of 
0.9.3, so I might as well take it myself.  If this is inappropriate (and, if 
so, I apologize), feel free to reset as necessary.
Assignee: maolson → andersma
Target Milestone: mozilla1.0 → mozilla0.9.3
Fix checked in to trunk on July 9.  <box> is still supported, of course, but all 
instances have been changed to <hbox> or <vbox>, modulo those affected by bug 
88332.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.