Last Comment Bug 736753 - Fix the includes in layout/svg/base/src so that we can stop including nsSVGSVGElement.h in nsSVGContainerFrame.h
: Fix the includes in layout/svg/base/src so that we can stop including nsSVGSV...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on:
Blocks: 379709
  Show dependency treegraph
 
Reported: 2012-03-17 10:55 PDT by Jonathan Watt [:jwatt]
Modified: 2012-03-18 13:13 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (7.21 KB, patch)
2012-03-17 10:55 PDT, Jonathan Watt [:jwatt]
longsonr: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] 2012-03-17 10:55:07 PDT
Created attachment 606885 [details] [diff] [review]
patch

There is no need for nsSVGContainerFrame.h to include nsSVGSVGElement.h. It unnecessarily slows down compile time by including unnecessary things, and it is preventing me adding layout/svg/base/src to LOCAL_INCLUDES in layout/generic/Makefile.in in the patch in bug 379709 without also adding content/svg/content/src. I plan to do some work soon to properly clean up the includes in layout/svg, but for now this cleans things up sufficiently to allow me to land the patch in bug 379709.
Comment 1 Jonathan Watt [:jwatt] 2012-03-17 11:00:29 PDT
The files where I've added includes for nsSVGUtils.h need that now for NS_STATE_SVG_NONDISPLAY_CHILD since they are no longer getting it included indirectly via nsSVGSVGElement.h.
Comment 2 Phil Ringnalda (:philor, back in August) 2012-03-18 13:13:55 PDT
https://hg.mozilla.org/mozilla-central/rev/b3142bc739d8

Note You need to log in before you can comment on or make changes to this bug.