Note: There are a few cases of duplicates in user autocompletion which are being worked on.

build with/without system nspr: hal/sandbox/PHal.ipdl

RESOLVED FIXED in mozilla14

Status

()

Core
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Takanori MATSUURA, Assigned: Takanori MATSUURA)

Tracking

Trunk
mozilla14
x86_64
Linux
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

5 years ago
hal/sandbox/PHal.ipdl includes prtime.h as "nspr/prtime.h". However most of other files include prtime.h as "prtime.h". And I cannot build Firefox with system NSPR because NSPR headers are installed at /usr/include/nspr4.
(Assignee)

Comment 1

5 years ago
Created attachment 606967 [details] [diff] [review]
Build with system NSPR.
Attachment #606967 - Flags: review?(jones.chris.g)
Attachment #606967 - Flags: review?(jones.chris.g) → review+
Duplicate of this bug: 736854
(Assignee)

Updated

5 years ago
Assignee: nobody → t.matsuu
Keywords: checkin-needed
Please provide a better commit message than "Build with system NSPR".
Keywords: checkin-needed
(Assignee)

Comment 4

5 years ago
Created attachment 607510 [details] [diff] [review]
hal/sandbox/PHal.ipdl can build with system NSPR

Only fix the commit message.
Carried over r+
Attachment #606967 - Attachment is obsolete: true
Attachment #607510 - Flags: review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 5

5 years ago
Created attachment 607515 [details] [diff] [review]
hal/sandbox/PHal.ipdl can build with system NSPR

Fit to the latest m-c.
Carried over r+.
Attachment #607510 - Attachment is obsolete: true
Attachment #607515 - Flags: review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/f88006706f72
Flags: in-testsuite-
Keywords: checkin-needed
Target Milestone: --- → mozilla14
https://hg.mozilla.org/mozilla-central/rev/f88006706f72
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.