Style editor ignores OS theme

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Style Editor
--
minor
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Navid Zamani, Unassigned)

Tracking

11 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The style editor ignores the OS theme, and displays in a weird dark theme instead that doesn’t match with anything.

It should look like defined by the OS. (Colors, widget style, fonts, etc)

Comment 1

6 years ago
All the devtools use a different theme to differentiate themselves from the normal Firefox UI. This design is intended.
(Reporter)

Comment 2

6 years ago
That is a thing that may be normal on systems like Windows, where there is no consistent UI style anyway. (Since many apps don’t care about it.)
But on Linux, this stands out as the only exception, and therefore makes it rather unpleasant. Especially when it’s in stark contrast with everything else.

But since those are styled by CSS, and Firefox is open source, I could write a optional patch, correct? (I’d modify the ebuild for Gentoo and add a use flag to enable the patch.)
(Reporter)

Comment 3

6 years ago
By the way: I just checked, and the style editor is actually the only one using those dark elements. (If only, because it’s the only thing that has more than the menu and a code editor frame. :)

Comment 4

6 years ago
(In reply to Navid Zamani from comment #3)
> By the way: I just checked, and the style editor is actually the only one
> using those dark elements. (If only, because it’s the only thing that has
> more than the menu and a code editor frame. :)

Actually, there is a patch to apply the dark theme to the Web Console, the Page Inspector uses the dark theme. Scratchpad may be a little different as it has less chrome.

A theme add-on can change the appearance of the tools. As far as I know, we don't currently plan to bundle in a system native look in the developer tools (I've cc'ed Stephen Horlander who has been managing our user interface).
We now have a light theme too. And all the tools are either all dark or all light.

I think that solves the purpose.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.