Last Comment Bug 736845 - Remove useless "container" div from about:home
: Remove useless "container" div from about:home
Status: RESOLVED FIXED
[qa-]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Dão Gottwald [:dao]
:
:
Mentors:
Depends on:
Blocks: 711157
  Show dependency treegraph
 
Reported: 2012-03-18 08:09 PDT by Dão Gottwald [:dao]
Modified: 2012-05-10 12:22 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (4.48 KB, patch)
2012-03-18 08:09 PDT, Dão Gottwald [:dao]
mak77: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2012-03-18 08:09:23 PDT
Created attachment 606971 [details] [diff] [review]
patch
Comment 2 Marco Bonardo [::mak] 2012-03-20 03:06:40 PDT
I think once it is merged, may be worth to have this in Aurora, since snippets are going to be rewritten better to give them stable document contents (yes, wouldn't be hard to workaround this, but no reason to not avoid that).
Comment 3 Dão Gottwald [:dao] 2012-03-20 03:08:59 PDT
> snippets are going to be rewritten better to give them stable document
> contents

What exactly does this mean with regards to this bug?
Comment 4 Marco Bonardo [::mak] 2012-03-20 03:21:26 PDT
snippets can modify css, for example when they changed the background to black for a day in the past. They may try to do that on "container" and get different results across versions.
Comment 5 Marco Bonardo [::mak] 2012-03-20 03:22:16 PDT
I actually forgot a comma in that phrase, "snippets are going to be rewritten, so better give them"
Comment 6 Mounir Lamouri (:mounir) 2012-03-20 03:56:15 PDT
https://hg.mozilla.org/mozilla-central/rev/70cdb996d790
Comment 7 Alex Keybl [:akeybl] 2012-03-20 13:31:51 PDT
Comment on attachment 606971 [details] [diff] [review]
patch

[Triage Comment]
Low risk patch in support of correctness in a new feature. Approved for Aurora 13.

Note You need to log in before you can comment on or make changes to this bug.