Last Comment Bug 736846 - about:home launcher buttons jerk down as the icons load
: about:home launcher buttons jerk down as the icons load
Status: RESOLVED FIXED
[qa!]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 711157
  Show dependency treegraph
 
Reported: 2012-03-18 08:11 PDT by Dão Gottwald [:dao]
Modified: 2012-05-22 09:54 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
verified


Attachments
patch (1.41 KB, patch)
2012-03-18 08:12 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Review
patch v2 (1.44 KB, patch)
2012-03-18 08:15 PDT, Dão Gottwald [:dao]
mak77: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Dão Gottwald [:dao] 2012-03-18 08:11:38 PDT

    
Comment 1 Dão Gottwald [:dao] 2012-03-18 08:12:02 PDT
Created attachment 606972 [details] [diff] [review]
patch
Comment 2 Dão Gottwald [:dao] 2012-03-18 08:15:36 PDT
Created attachment 606973 [details] [diff] [review]
patch v2

Hm, I guess the restorePreviousSession icon should also have the width specified?
Comment 3 Marco Bonardo [::mak] 2012-03-19 13:21:54 PDT
Comment on attachment 606973 [details] [diff] [review]
patch v2

Review of attachment 606973 [details] [diff] [review]:
-----------------------------------------------------------------

Well, in the restorePreviousSession case, the label is never below the button, so it's unlikely height is needed for this specific bug.  Though, I assume since the whole button moves down, it's worth to have it, to do proper calculation earlier.  Is there any other reason for it I'm missing?
Comment 5 Matt Brubeck (:mbrubeck) 2012-03-20 10:42:28 PDT
https://hg.mozilla.org/mozilla-central/rev/307490794b3d
Comment 6 Alex Keybl [:akeybl] 2012-03-20 13:32:11 PDT
Comment on attachment 606973 [details] [diff] [review]
patch v2

[Triage Comment]
Low risk patch in support of correctness in a new feature. Approved for Aurora 13.
Comment 8 Vlad [QA] 2012-05-21 00:49:36 PDT
I've loaded the about:home page in
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0 beta 4
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0 beta 4

The buttons did not jerk as the site was loading. 
There are other steps in verifying this?

Thanks
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-22 09:54:36 PDT
(In reply to Vlad [QA] from comment #8)
> The buttons did not jerk as the site was loading. 
> There are other steps in verifying this?
> 
> Thanks

I think that's good enough.

Note You need to log in before you can comment on or make changes to this bug.