Last Comment Bug 736875 - Compositor perf warning need to be filtered up to 15ms
: Compositor perf warning need to be filtered up to 15ms
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM Linux
: -- normal (vote)
: mozilla14
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 11:51 PDT by Oleg Romashin (:romaxa)
Modified: 2013-12-10 10:00 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
fixed


Attachments
Filter ShadowLayersParent.cpp compositor warnings up to 15 ms (1.15 KB, patch)
2012-03-18 11:53 PDT, Oleg Romashin (:romaxa)
bgirard: review+
Details | Diff | Splinter Review

Description Oleg Romashin (:romaxa) 2012-03-18 11:51:25 PDT
http://hg.mozilla.org/mozilla-central/rev/8822397fc42d - did not found any bug or review for that check-in

but on IPC XUL fennec it throw lot  of messages like:
Compositor: Layers update took 1 ms (blocking gecko).
Compositor: Layers update took 0 ms (blocking gecko).
Compositor: Layers update took 0 ms (blocking gecko).
Comment 1 Oleg Romashin (:romaxa) 2012-03-18 11:53:37 PDT
Created attachment 606990 [details] [diff] [review]
Filter ShadowLayersParent.cpp compositor warnings up to 15 ms
Comment 2 Benoit Girard (:BenWa) 2012-03-18 12:54:47 PDT
Comment on attachment 606990 [details] [diff] [review]
Filter ShadowLayersParent.cpp compositor warnings up to 15 ms

I can review this. It used to warn after 15ms and was intended to work that way but it got changed around in refactoring.
Comment 4 Matt Brubeck (:mbrubeck) 2012-03-19 10:23:31 PDT
https://hg.mozilla.org/mozilla-central/rev/8cf4975502ca

Note You need to log in before you can comment on or make changes to this bug.