nsWebBrowserPersist should munge src= attributes to relative paths

VERIFIED FIXED in mozilla0.9

Status

defect
VERIFIED FIXED
19 years ago
4 months ago

People

(Reporter: jud, Assigned: adamlock)

Tracking

Trunk
mozilla0.9
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Our current implementation generates absolute urls for src= attributes when we
should be using relative (for transportability reasons).
Blocks: 70229
All the code for saving out the new URL is in 
nsWebBrowserPersist::FixupNodeAttribute. It should be possible to modify this to 
use relative paths.
I have a patch for the relative files problem but it exposes a problem which the 
BASE tag which must be resolved before it is complete.

The problem is that if a document contains a <BASE> element then all relative 
URLS to files will be resolved to that address and not onto the file path. I've 
commented out the lines that insert a BASE tag but it means relative anchor 
links in the page do not work.

To make relative files and anchors both work. I will have to change the fix up 
code so that the BASE tag is removed and all relative links are made into 
absolute ones.
Blocks: 64833
Target Milestone: --- → mozilla0.9
These changes look good... (r=rpotts)

-- rick
looks fine to me too, sr=blizzard
Fix is checked in
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Correction: Changing QA contact for the Embed API bugs to David Epstein.
QA Contact: mdunn → depstein
changed QA contact to dsirnapalli. He's looking at this interface.
QA Contact: depstein → dsirnapalli
-- marking as verified.
Status: RESOLVED → VERIFIED
No longer blocks: 64833
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.