tinymce not working if more then one instance in a form in firefox 11

RESOLVED DUPLICATE of bug 737784

Status

()

--
major
RESOLVED DUPLICATE of bug 737784
7 years ago
7 years ago

People

(Reporter: teoballen, Unassigned)

Tracking

({regression})

11 Branch
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I opened a form with 3 instances of the tinymce editor


Actual results:

The text in the editor only show up in the last on. When I open html code view the code is there.


Expected results:

I should see text in all 3 instances of tinymce.
It works well in firefox prior to firefox 11
(Reporter)

Updated

7 years ago
Severity: normal → major
Priority: -- → P1
Please provide a testcase
Priority: P1 → --

Comment 2

7 years ago
I observed similar issues using Hannon Hill's Cascade Server CMS (v 6.10.5) which uses  multiple TinyMCE windows elements to edit portions of a web page. Downgrading to Firefox 10.0 ESR fixed the issue.

Comment 3

7 years ago
Bug is also noted on TinyMCE bugtracker page at http://www.tinymce.com/develop/bugtracker.php - ID# 5089 - Latest FF update locks down multiple TinyMCE instances

Comment 4

7 years ago
I have the same problem with FireFox Mac and Windows.
Can anyone provide a public URL/testcase ?
Component: Untriaged → General
Keywords: regression
Product: Firefox → Core
QA Contact: untriaged → general

Comment 6

7 years ago
upgrading to last stable tinymce (3.4.9) solves the problem

Comment 7

7 years ago
Unfortunately, that's not a quick/easy/possible solution for those of us with sites with millions of users that depend on highly customized plugins that we would lose/have to rewrite if we upgraded.

Comment 8

7 years ago
I believe you can test it at http://www.iknowbase.com/tinymce.html

Comment 9

7 years ago
(In reply to me from comment #7)
> Unfortunately, that's not a quick/easy/possible solution for those of us
> with sites with millions of users that depend on highly customized plugins
> that we would lose/have to rewrite if we upgraded.

That is exactly true. I tried to upgrade to the latest version, but then none of the functionality worked anymore. I don't think a bug in FF should oblige us to upgrade a piece of server software, all the more when other browsers (including IE!) do not have this problem.

Comment 10

7 years ago
(In reply to Robert from comment #9)
> (In reply to me from comment #7)
> > Unfortunately, that's not a quick/easy/possible solution for those of us
> > with sites with millions of users that depend on highly customized plugins
> > that we would lose/have to rewrite if we upgraded.
> 
> That is exactly true. I tried to upgrade to the latest version, but then
> none of the functionality worked anymore. I don't think a bug in FF should
> oblige us to upgrade a piece of server software, all the more when other
> browsers (including IE!) do not have this problem.

Remember, though, that this is not necessarily a bug in FF. 

It could also be that the version 3.2.7 of tinymce contains some javascript flaws and the latest FF release might be more restrictive and prevent thus tinymce from working correctly. It would work because the other browsers are not catching these javascript flaws. In which case I would say we can't input the problem to firefox.

Of course this can be more unlikely, but we don't know the cause for now.
Eirik, thanks for the link!

The behavior changed in this range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1bd7482ad4d1&tochange=fafaf614791f

I really wish more people would test the Aurora/Beta builds.  The problem has been present since early November 2011, and this is the first we heard of it.  :(

Bug 699351 in that range looks suspicious...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 737784
> The problem has been present since early November 2011

I meant early December, of course.  ;)
This should be fixed in the next nightly, someone should test that to ensure this is a duplicate.

Comment 15

7 years ago
Tested with nightly 14.01 on a Mac OS X and can't reproduce the bug with the above test link (http://www.iknowbase.com/tinymce.html). So fixed for me.
You need to log in before you can comment on or make changes to this bug.