Dialogs on Windows don't look like dialog windows

VERIFIED DUPLICATE of bug 7372

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 7372
19 years ago
13 years ago

People

(Reporter: Michael Lowe, Assigned: davidm)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Something needs to be done to make Mozilla dialog windows look more like real
Windows dialogs.   At present it seems that nsAppShellService creates a
nsWebShellWindow, and nsWebShellWindow creates a nsWindow.   However, the
nsWindow is created with a border style eBorderStyle_window.   Instead, in
this case the nsWindow should be created with a border style
eBorderStyle_dialog, or else nsWebShellWindow should create a nsDialog instead
of a nsWindow.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 7372 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
Changing component to Browser-General. (HTML Dialogs is going away, and this bug 
doesn't look suitable for XP Apps on quick glance.)
Component: HTML Dialogs → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.