Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Remove deprecated dnd methods from feed subscribe dialog, several enhancements

RESOLVED FIXED in Thunderbird 14.0

Status

MailNews Core
Feed Reader
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: alta88, Assigned: alta88)

Tracking

(Blocks: 1 bug)

unspecified
Thunderbird 14.0
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 607246 [details] [diff] [review]
patch.

1. remove com interfaces and nsDragAndDrop in favor of getting everything from the event.dataTransfer.
2. allow copy of feeds to other accounts.
3. try harder to get valid urls; support dnd from chrome/safari links (ie8/9 dnd doesn't have the info in dt though).  for both folderpane and dialog.
Assignee: nobody → alta88
(Assignee)

Updated

5 years ago
Duplicate of this bug: 272473
(Assignee)

Updated

5 years ago
Blocks: 444813
(Assignee)

Updated

5 years ago
Attachment #607246 - Flags: review?(dbienvenu)
(Assignee)

Comment 3

5 years ago
Created attachment 607995 [details] [diff] [review]
patch.

tweak to make a reusable func.
Attachment #607246 - Attachment is obsolete: true
Attachment #607246 - Flags: review?(dbienvenu)
Attachment #607995 - Flags: review?(dbienvenu)

Comment 4

5 years ago
Comment on attachment 607995 [details] [diff] [review]
patch.

this seems to work ok. My one question is about imap - I was able to drag an rss folder to an imap account once, and the messages were copied, but then I couldn't actually read the messages. When I tried to recreate the issue, I was unable to copy the rss feed to an imap account because creating the folder failed because of hierarchy delimiter issues (we were using ^ instead of . for some reason). The code w/o your patch failed the same way, so I'm not going to minus the patch for that. But, would you expect feeds to work if they're in imap accounts? Is drag&drop of feeds to imap accounts useful?
Attachment #607995 - Flags: review?(dbienvenu) → review+

Comment 5

5 years ago
oh, I should say, the patch has bit-rotted a little bit - feed-subscriptions.xul doesn't quite apply.
(Assignee)

Comment 6

5 years ago
Created attachment 610122 [details] [diff] [review]
unbitrotted patch for checkin.
Attachment #607995 - Attachment is obsolete: true
Attachment #610122 - Flags: review+
(Assignee)

Comment 7

5 years ago
(In reply to David :Bienvenu from comment #4)
> Comment on attachment 607995 [details] [diff] [review]
> patch.
> But, would you expect feeds to work
> if they're in imap accounts? Is drag&drop of feeds to imap accounts useful?

currently a message is a 'feed' only if its folder.server.type == "rss", otherwise it's subject to remote content and the web page won't be loaded.  but, the mbox (summary) should be viewable no differently in imap than in any other server type, ie local folders etc.

'feedness' should be a property of the message not its folder, bug 522645.  now that bug 647699 has been recently fixed, a property can be added to do this, going forward.
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 8

5 years ago
btw, the 'copy feeds to other accounts' meant the feed subscription in the Subscribe dialog (not folder/messages in folderpane).

the folderpane is extremely confusing, even to me.  a 'feed' is not the folder.  a folder in a feed account may have 0, 1, or more than 1 feed subscriptions (just a folder property).  and the user can't tell without looking in the Subscribe dialog.
http://hg.mozilla.org/comm-central/rev/43c6ccec3b1e

BTW, I had a lot of difficulty getting your patch to apply due to bad hunks. Please make sure you're using the settings shown in the article below for the patches you submit.
https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite?
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 14.0

Updated

5 years ago
Blocks: 795002
You need to log in before you can comment on or make changes to this bug.