Closed Bug 737128 Opened 8 years ago Closed 7 years ago

crash in mozilla::gl::GLContextEGL::ReleaseSurface GL on Droid X, Droid 2, Droid Pro, MB526, MotoA953

Categories

(Firefox for Android :: General, defect, critical)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 752368
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: cpeterson, Assigned: ajuma)

References

Details

(4 keywords, Whiteboard: [native-crash][gfx])

Crash Data

This GL crash seems to be a Maple regression and only crashes on Droid X.

https://crash-stats.mozilla.com/report/index/b0691793-c9a4-44b1-9cf4-b4cec2120318
https://crash-stats.mozilla.com/report/index/80fa1560-56a3-43ab-8879-41bb22120317
https://crash-stats.mozilla.com/report/index/68db0739-9ffa-48a2-933a-6d2352120317
https://crash-stats.mozilla.com/report/index/4f3fcded-3352-4962-81e7-4dade2120316
https://crash-stats.mozilla.com/report/index/7b9be12e-6491-4aa1-bc3e-c2d182120315


EGL? EGL+ AdapterVendorID: mapphone_cdma, AdapterDeviceID: DROID X.
AdapterDescription: 'Android, Model: 'DROID X', Product: 'cm_shadow', Manufacturer: 'Motorola', Hardware: 'mapphone_cdma''.
GL Context? GL Context+ GL Layers? GL Layers+ 
Motorola DROID X
verizon/cm_shadow/shadow:4.0.3/MR1/eng.x13thangelx.20120308.165239:eng/test-keys


0 libEGL.so libEGL.so@0xd194
1 libEGL.so libEGL.so@0xcfef
2 libxul.so mozilla::gl::GLContextEGL::ReleaseSurface gfx/gl/GLContextProviderEGL.cpp:444
3 libxul.so mozilla::layers::CompositorParent::PauseComposition gfx/layers/ipc/CompositorParent.cpp:108
4 libxul.so RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run ipc/chromium/src/base/tuple.h:383
5 libxul.so MessageLoop::RunTask ipc/chromium/src/base/message_loop.cc:318
6 libxul.so MessageLoop::DeferOrRunPendingTask ipc/chromium/src/base/message_loop.cc:326
7 libxul.so MessageLoop::DoWork ipc/chromium/src/base/message_loop.cc:426
8 libxul.so base::MessagePumpDefault::Run ipc/chromium/src/base/message_pump_default.cc:23
9 libxul.so MessageLoop::RunInternal ipc/chromium/src/base/message_loop.cc:208
10 libxul.so MessageLoop::Run ipc/chromium/src/base/message_loop.cc:201
11 libxul.so base::Thread::ThreadMain ipc/chromium/src/base/thread.cc:156
12 libxul.so ThreadFunc ipc/chromium/src/base/platform_thread_posix.cc:26
13 libc.so libc.so@0x1334a
14 libc.so libc.so@0x12e76
15 libEGL.so libEGL.so@0x23e82
Socorro report bp-7b9be12e-6491-4aa1-bc3e-c2d182120315
Crash Signature [@ mozilla::gl::GLContextEGL::ReleaseSurface]
Crash Signature: [@ mozilla::gl::GLContextEGL::ReleaseSurface]
This is happening when we're attempting to call eglMakeCurrent to release the surface. It could be that we're attempting to release the surface after we've already gone into the background. If so, this is related to Bug 735230 (in that we need to ensure that we're not making GL calls while in the background), and a possible fix (that we might end up implementing for Bug 735230) is to make CompositorParent::SchedulePauseOnCompositorThread block until the compositor is actually paused.
Whiteboard: [native-crash][gfx]
Version: Trunk → Firefox 14
blocking-fennec1.0: --- → -
#19 crasher on 14.0a1, re-noming
blocking-fennec1.0: - → ?
#19 is too low. Please renom if it spikes.
blocking-fennec1.0: ? → -
Keywords: topcrash
Since we're crashing on eglMakeCurrent(EGL_DISPLAY(), EGL_NO_SURFACE, EGL_NO_SURFACE, EGL_NO_CONTEXT), something we're doing before this call is getting the driver into a bad state. To figure out what that something is, we'll need steps to reproduce this.
blocking-fennec1.0: - → ?
Sorry, didn't mean to re-nom.
blocking-fennec1.0: ? → ---
blocking-fennec1.0: --- → -
renoming because it has become within the top 10 crash.
blocking-fennec1.0: - → ?
Keywords: topcrash
This crash spiked on the April 3rd build. Since then, there have been a total of 2 crashes with this signature.
blocking-fennec1.0: ? → -
There are several crashes on recent builds, #6 now, renoming.
blocking-fennec1.0: - → ?
Let's wait and see how this crash changes during beta
blocking-fennec1.0: ? → -
Curiously, this crash is our #1 or #2 topcrash for the past 1/3/7 days on Nightly 15, but does not show up at all on Aurora 14. Are there any fixes in m-a that did not land in m-c?
(In reply to Chris Peterson (:cpeterson) from comment #12)
> Curiously, this crash is our #1 or #2 topcrash for the past 1/3/7 days on
> Nightly 15, but does not show up at all on Aurora 14. Are there any fixes in
> m-a that did not land in m-c?

Looking at the install time and OS columns in the crash reports on Nightly 15, it looks like all the crashes are from ~3 users. So it's possible that we're not hitting this on Aurora 14 yet just because we don't have enough Droid X users there so far.
A reddit user says this makes native fennec basically unusable on their Droid X.  This user is running Cyanogenmod 9; I don't know if that's related to the crash or not:
http://www.reddit.com/r/firefox/comments/t7kle/android/c4kbapp
Should we try to get a couple of Droid X's in the office?  (one for dev one for qa?)
Keywords: relnote
(In reply to Naoki Hirata :nhirata from comment #15)
> Should we try to get a couple of Droid X's in the office?  (one for dev one
> for qa?)

we should already have some. Wes, if I recall you have one, right?
This crash is now the top (unfixed) crash on Nightly 15.
Should we consider Droid X (4.9% of Android devices - source [1]) as unsupported?

[1]: https://docs.google.com/spreadsheet/ccc?key=0ArpSb7XMTvzydDhVNWFXbXRkQ3VoQW4yaWptTjJjY3c&authkey=COzTgpEG&authkey=COzTgpEG
Renominating since this is a high top crasher in Nightly.

This is only the #22 crash in Aurora, but if it makes the browser unusable on this device then it might not become a top crash there (because Droid X owners will just uninstall the browser after a few crashes).
blocking-fennec1.0: - → ?
blocking-fennec1.0: ? → +
Investigating the crash reports show that it also reproduces on the Droid 2 and the Droid Pro.
Summary: mozilla::gl::GLContextEGL::ReleaseSurface GL crash on Droid X → mozilla::gl::GLContextEGL::ReleaseSurface GL crash on Droid X, Droid 2, Droid Pro
The first days of 14.0b1 show other impacted devices. See also bug 749580 which is likely a dupe of this bug.
Summary: mozilla::gl::GLContextEGL::ReleaseSurface GL crash on Droid X, Droid 2, Droid Pro → crash in mozilla::gl::GLContextEGL::ReleaseSurface GL on Droid X, Droid 2, Droid Pro, MB526, MotoA953
From yesterday's data:

mozilla::gl::GLContextEGL::ReleaseSurface - 140 crashes, on those devices:
Motorola DROIDX 	72
Motorola MB526 	42
Motorola DROID2 	10
Unknown DROIDX 	6
Motorola Droid X 	4
Motorola MotoA953 	3
Motorola DROID Pro 	2
Motorola MB525 	1
Blocks: 749580
No crashes post 5/18 in this bug or 749580 either.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752368
Haven't seen this reappear since this has been closed out.
You need to log in before you can comment on or make changes to this bug.