Fix AudioManager and sydney_audio_gonk on ICS

RESOLVED FIXED

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mwu, Assigned: mwu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Created attachment 607290 [details] [diff] [review]
Fix audio

This is a patch from an anonymous silicon vendor contributor. It works for me.
Attachment #607290 - Flags: review?(jones.chris.g)
Attachment #607290 - Flags: review?(gal)
(Assignee)

Updated

6 years ago
Attachment #607290 - Attachment description: Anonymous Silicon Vendor contributor → Fix audio
Comment on attachment 607290 [details] [diff] [review]
Fix audio

Hi, we had discussed using a compat header to avoid having to do these ifdef's in gecko.
Attachment #607290 - Flags: review?(jones.chris.g) → review-
Created attachment 609091 [details] [diff] [review]
part 1: Import the Gingerbread/Ice Cream Sandwich-compatible audio client code
Attachment #607290 - Attachment is obsolete: true
Attachment #607290 - Flags: review?(gal)
Attachment #609091 - Flags: review+
Created attachment 609092 [details] [diff] [review]
part 2: Port AudioManager and libsydneyaudio to the new import

I'm not enthused about this port but it's going away soon, so OK.  Issues
 - we "just happen" to be GB and ICS compatible.  There's no reason why this should be the case.  It's nice that things worked out this way, but the real fix is to directly talk to the audio HAL.  That work is underway.
 - need to file a followup for the setForce/getForce issue.  I don't fully understand what's going wrong in the ICS codebase there.

mwu, please file a followup bug with the reasons why that code is commented out.
Attachment #609092 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/2fae50aeacf1
https://hg.mozilla.org/mozilla-central/rev/7e51d72827a6

Please file followup.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Blocks: 739090
(Assignee)

Updated

6 years ago
Duplicate of this bug: 736933
You need to log in before you can comment on or make changes to this bug.