Closed Bug 737215 Opened 8 years ago Closed 3 years ago

The About window of Nightly and Aurora builds should display the build id

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: strugee, Unassigned)

References

Details

(Whiteboard: [needs the owner's decision])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20120319 Firefox/14.0a1
Build ID: 20120319031122

Steps to reproduce:

1. Go to the browser's About window


Actual results:

The version number and date are shown, e.g. "14.0a1 (2012-03-19)". As we're talking about Nightly and Aurora builds, the version number is largely unhelpful.


Expected results:

The build number should be displayed somehow in this window. Ways this could be done include replacing the date (or even version number), adding the build number alongside the date (and/or version number), etc.
OS: Mac OS X → All
Hardware: x86 → All
Nah, that's for beta. I'm talking about Nightly builds. (Nightly builds currently show the build date, but we should think about including the build id as well IMO. I'm not sure which of these is more useful to developers in bug reports.)
Cross-referencing other bugs about this:
- bug 596931 for release (wontfix)
- Bug 675192 for beta

Since I haven't found a comment with a decision not to do this, confirming the report to get it off the untriaged list and linking it to the bug where the about dialog was implemented to make it easier to find.

FWIW, I think the date is usually enough. When it's not, the revision link from about:buildconfig is more useful than a build id.
Blocks: 579547
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
QA Contact: untriaged → general
Whiteboard: [needs the owner's decision]
Closing as WONTFIX since this was filed 5 years ago and the existing information is probably sufficient anyway, given the above comment.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.