Some profiles have invalid usernames

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
--
blocker
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: tofumatt, Assigned: tofumatt)

Tracking

Details

(Whiteboard: [rel:03/21/2012])

(Assignee)

Description

6 years ago
IRC nicks were moved over to usernames, but it seems not sanitized properly, so usernames like "odin, odinm" exist. This causes problems because they aren't valid Django Auth usernames (less of a big deal) but are also not caught by our current URLconf (which doesn't check for spaces/commas -- bigger deal). This will cause 500 errors on any page with a link to an un-resolvable profile URL.
(Assignee)

Comment 1

6 years ago
The fix here is to write a migration that changes all usernames to valid ones. Working on it.
Assignee: nobody → tofumatt
Severity: normal → blocker
Whiteboard: [rel:03/21/2012]

Updated

6 years ago
Duplicate of this bug: 736596

Comment 3

6 years ago
Commit pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/b4e9ae6305f84f31789d9d01af5cf6c3d3ebbd78
Cleanup usernames (fix bug 737263)

Migrate usernames to be free of unsupported characters.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
QA verified on prod - bumping to verified - as far as I can tell we're not receiving any of the tracebacks that we were previously seeing (bug 736596).
Status: RESOLVED → VERIFIED

Updated

6 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Version: unspecified → other
You need to log in before you can comment on or make changes to this bug.