IonMonkey: Assertion failure: opd->type() == phi->type(), at ion/Lowering.cpp:1549

RESOLVED DUPLICATE of bug 747271

Status

()

--
major
RESOLVED DUPLICATE of bug 747271
7 years ago
7 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Other Branch
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:update,ignore])

(Reporter)

Description

7 years ago
The following testcase asserts on ionmonkey revision b5b6e6aebb36 (run with --ion -n -m --ion-eager):


function TestCase(n, d, e, a) {}
var SECTION = "11.10-1";
var shiftexp = 0;
var addexp = 0;
  for ( addpow = 0; addpow < 33; addpow++ ) {
    addexp += Math.pow(2, addpow);
    new TestCase( SECTION, And( shiftexp, addexp ), shiftexp & addexp );
}
function ToInt32BitString( n ) {
  var sign = ( n < 0 ) ? -1 : 1;
  for ( p = 30; p >=0; p-- ) {
    if ( (sign == 1 ) ? sign * n >= Math.pow(2,p) : sign * n > Math.pow(2,p) ) {
      n = sign * Math.pow( 2, p );
    }
  }
}
function And( s, a ) {
  var ba = ToInt32BitString( a );
}
(Reporter)

Updated

7 years ago
Whiteboard: [jsbugmon:update]
(Reporter)

Comment 1

7 years ago
JSBugMon: The testcase found in this bug no longer reproduces (tried revision c45668383f51).
(Reporter)

Updated

7 years ago
Whiteboard: [jsbugmon:update] → [jsbugmon:update,ignore]
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747271
You need to log in before you can comment on or make changes to this bug.