Hang when spawning processes

RESOLVED DUPLICATE of bug 837390

Status

()

RESOLVED DUPLICATE of bug 837390
7 years ago
6 years ago

People

(Reporter: sfink, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When running with the Gecko Profiler addon installed and enabled, anything that starts up an external process hangs the browser.

strace shows an endless series of

  clone (getting interrupted, and returning ERESTARTNOINTR)
  SIGPROF received
  rt_sigreturn

STR:
 install geckoprofiler.xpi
 open 'mailto:god@heaven.mil' (or click on a PDF link)

This happens even if I disable the addon first, but disabling seems to be broken as well because gdb still shows SIGPROF signals being received, and if you can find the right thread id, strace shows a nanosleep/tgkill loop still running.
(Reporter)

Updated

7 years ago
OS: All → Linux
Hardware: All → x86_64
(Reporter)

Comment 1

7 years ago
I am using the profiling nightly on 64-bit Fedora 14.
I missed this report. Stopping the profiler likely leaves some state behind. Are you still seeing this problem?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837390
You need to log in before you can comment on or make changes to this bug.