doesn't display inline images utf-8 (If ? is used in filename/name value, Tb fails to resolve cid: url and embed image of HTML mail is not shown)

RESOLVED DUPLICATE of bug 731120

Status

MailNews Core
MIME
RESOLVED DUPLICATE of bug 731120
6 years ago
6 years ago

People

(Reporter: jason, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 607450 [details]
Example message source with names and emails redacted.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.79 Safari/535.11

Steps to reproduce:

Tried to open a message with inline utf-8 named jpg attachment. This message was sent from an iphone.


Actual results:

The image does not show inline. When "View -> Message Body As -> Plain Text" is select I am able to save or open the image but the message never displays inline.


Expected results:

The image should render the same as non-utf-8 named jpg images.
That image isn't Inline because "Content-Disposition: attachment" is used.
You should see it however in the attachment list.
It should be "Content-Disposition: inline" if that image should appear inline.
(In reply to Matthias Versen (Matti) from comment #1)
> That image isn't Inline because "Content-Disposition: attachment" is used.
> You should see it however in the attachment list.
> It should be "Content-Disposition: inline" if that image should appear inline.

Why "cid: url/Content-ID: resolution" of valid/correct multipart/related{text/html + image/jpeg} with "View/Message Body As/Original HEML" should be affected by attachmnet/inline of Content-Disposition?
It's applicable only on multipart/mixed, isn't it?
Matthias Versen, do you actually see the not-shown image/jpeg part of the test mail at attachment pane of Tb with "View/Mssage Body/Original HTML or Simple HTML"?

Because patch for bug 674473 is landed on Tb 11, "non-displayed jpeg part in multipart/related with View/Message Body As/Plain Text" is shown as if attachment again from Tb 11, as far as filename/name is specified or attachment is specified.
Please don't confuse this phenomenon after fix of bug 674473 with this bug's problem.

(In reply to jason from comment #0)
> Created attachment 607450 [details]
> Example message source with names and emails redacted.

Header of image/jpeg part. "?" is contained in filename/name.
With "View/Message Body As/Original HTML", broken image is shown.
> Content-Type: image/jpeg; name="??.jpg"
> Content-Transfer-Encoding: base64
> Content-Id: <6E4D7789-81E6-4B3D-BDE1-3D13D5FEFF9A>
> Content-Disposition: attachment; filename="??.jpg"

If "?" in filename/name is removed(replaced by "_" in test), embed image is shown as expected with "View/Message Body As/Original HTML".
> Content-Type: image/jpeg; name="__.jpg"
> Content-Transfer-Encoding: base64
> Content-Id: <6E4D7789-81E6-4B3D-BDE1-3D13D5FEFF9A>
> Content-Disposition: attachment; filename="__.jpg"

For the broken image in Forward of original mail("?" in filename/name), Location: of image property is shown like next.
> mailbox:///C:/wada/@@@/Mail-X/Inbox.sbd/Question-in-filename.sbd/bug-737330-01-Original?number=0&part=1.2&filename=??.jpg
Cause is : ? in filename or name is not escaped by Tb even though Tb uses URL format as internal path of resource.
This is essentially same problem as bug 729742.
Status: UNCONFIRMED → NEW
Component: General → MIME
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: general → mime
Woops, I forgot that I had opened bug 731120...
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731120
Summary: doesn't display inline images utf-8 → doesn't display inline images utf-8 (If ? is used in filename/name value, Tb fails to resolve cid: url and embed image of HTML mail is not shown)
You need to log in before you can comment on or make changes to this bug.