Assertion failure: *pc != JSOP_SETARG, at js/src/jsanalyze.cpp:1655

RESOLVED DUPLICATE of bug 740446

Status

()

--
critical
RESOLVED DUPLICATE of bug 740446
7 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {assertion, testcase})

Trunk
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: js-triage-needed [jsbugmon:update,ignore])

(Reporter)

Description

7 years ago
The following test asserts on mozilla-central revision 58a2cd0203ee (options -m -n):


const libdir = "foo";
function strictAssignOuterParamPSYCH(p) {
  "use strict";
  var [p, anonymous]  = ignoreWhitespace( foo, bar ) ? this : this;
  return arguments;
}
a1 = strictAssignOuterParamPSYCH();
Depends on: 708892
(Reporter)

Updated

6 years ago
Whiteboard: js-triage-needed → js-triage-needed [jsbugmon:update,bisect,bisectfix]
(Reporter)

Updated

6 years ago
Whiteboard: js-triage-needed [jsbugmon:update,bisect,bisectfix] → js-triage-needed [jsbugmon:update,ignore]
(Reporter)

Comment 1

6 years ago
JSBugMon: The testcase found in this bug no longer reproduces (tried revision f9a8fdb08193).
JSBugMon: Fix Bisection requested, result:
autoBisect shows this is probably related to the following changeset:

The first good revision is:
changeset:   91358:fa24b215d49e
user:        Luke Wagner
date:        Mon Apr 02 08:58:30 2012 -0700
summary:     Bug 740446 - make 'arguments' more like a normal local binding (r=bhackett)
(Reporter)

Comment 2

6 years ago
luke, is the fix in comment 1 the right one for this bug? can I close this as dup?

Comment 3

6 years ago
Seems likely.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 740446
You need to log in before you can comment on or make changes to this bug.