All users were logged out of Bugzilla on October 13th, 2018

caldav autoconfig via principals lookup

RESOLVED DUPLICATE of bug 306495

Status

RESOLVED DUPLICATE of bug 306495
7 years ago
5 years ago

People

(Reporter: jesse.thompson, Unassigned)

Tracking

Lightning 1.3

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

CalDAV configuration can be tricky for users who manage lots of sub-calendars or who have a hard time typing in long URLs.  It would be ideal if Lightning would use the principles lookup feature to assist the user in configuring their calendar.  i.e. the user would just need to type https://calendar.example.org which would prompt Lightning to try the common paths to /principles, prompt the user for username/password, then show a list of calendar for the user to choose from.

There is an add-on that accomplishes this - http://xul.addons.free.fr/caldav-easy-config/ - but ideally this feature should be part of core Lightning.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 306495

Updated

5 years ago
Summary: caldav autoconfig via principles lookup → caldav autoconfig via principals lookup
You need to log in before you can comment on or make changes to this bug.