Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Intermittent browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | Test timed out | Found a tab after previous test timed out

RESOLVED FIXED in Firefox 13

Status

()

Firefox
Developer Tools
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: vporof)

Tracking

({intermittent-failure})

14 Branch
Firefox 14
x86
Windows 7
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox13 fixed, firefox14 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 607575 [details]
screenshot

https://tbpl.mozilla.org/php/getParsedLog.php?id=10210450&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound opt test mochitest-other on 2012-03-20 05:02:40 PDT for push 60dd3e5fe989

INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight01.js | finished in 584ms
TEST-INFO | checking window state
TEST-START | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | Highlighting a node didn't work properly.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | After highlighting a node, it should be highlighted. D'oh.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | Test timed out
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | finished in 30036ms
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | Found a tab after previous test timed out: data:text/html,<DOCTYPE%20html><html><head><title>Three%20Laws</title></head><body><div%20id='first-law'>A%20robot%20may%20not%20injure%20a%20human%20being%20or,%20through%20inaction,%20allow%20a%20human%20being%20to%20come%20to%20harm.</div><div>A%20robot%20must%20obey%20the%20orders%20given%20to%20it%20by%20human%20beings,%20except%20where%20such%20orders%20would%20conflict%20with%20the%20First%20Law.</div><div>A%20robot%20must%20protect%20its%20own%20existence%20as%20long%20as%20such%20protection%20does%20not%20conflict%20with%20the%20First%20or%20Second%20Laws.</div><div%20id='far-far-away'%20style='position:%20absolute;%20top:%20250%;'>I%20like%20bacon.</div><body></html>
TEST-INFO | checking window state
TEST-START | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight03.js
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight03.js | Highlighting a node didn't work properly.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight03.js | After highlighting a node, it should be highlighted. D'oh.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight03.js | Unhighlighting a should remove the current selection.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight03.js | After unhighlighting a node, it shouldn't be highlighted anymore. D'oh.
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight03.js | finished in 600ms
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

5 years ago
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 42

5 years ago
Created attachment 609671 [details] [diff] [review]
v1
Attachment #609671 - Flags: review?(rcampbell)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 609671 [details] [diff] [review]
v1

ok, but would prefer a version that gets rid of those requestLongerTimeouts.
Attachment #609671 - Flags: review?(rcampbell) → review+
(Assignee)

Comment 47

5 years ago
(In reply to Rob Campbell [:rc] (:robcee) from comment #46)
> Comment on attachment 609671 [details] [diff] [review]
> v1
> 
> ok, but would prefer a version that gets rid of those requestLongerTimeouts.

Pushed to try a version without them. Let's see what happens.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 57

5 years ago
Created attachment 610065 [details] [diff] [review]
[land me] v2
(Assignee)

Comment 58

5 years ago
(In reply to Victor Porof from comment #47)
> (In reply to Rob Campbell [:rc] (:robcee) from comment #46)
> > Comment on attachment 609671 [details] [diff] [review]
> > v1
> > 
> > ok, but would prefer a version that gets rid of those requestLongerTimeouts.
> 
> Pushed to try a version without them. Let's see what happens.

It worked without any requestLongerTimeout \o/
Attachment #609671 - Attachment is obsolete: true
https://hg.mozilla.org/integration/fx-team/rev/014c39d29e30
Whiteboard: [orange] → [orange][fixed-in-fx-team]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/014c39d29e30
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [orange][fixed-in-fx-team] → [orange]
Target Milestone: --- → Firefox 14
Comment hidden (Treeherder Robot)
Comment on attachment 610065 [details] [diff] [review]
[land me] v2

[Approval Request Comment]
Regression caused by (bug #): new code 
User impact if declined: none
Testing completed (on m-c, etc.): been on m-c for 2 weeks. Test failures stopped.
Risk to taking this patch (and alternatives if risky): none, testfix only
String changes made by this patch: none
Attachment #610065 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #610065 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/381eb64690d8
status-firefox14: --- → fixed

Updated

5 years ago
status-firefox13: --- → fixed
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.