pre connect http sessions on link hover

RESOLVED DUPLICATE of bug 881804

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 881804
7 years ago
3 years ago

People

(Reporter: mcmanus, Unassigned)

Tracking

({privacy-review-needed})

13 Branch
x86_64
Linux
privacy-review-needed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Snappy:P2][http-conn])

(Reporter)

Description

7 years ago
On Tue, Mar 20, 2012 at 12:44 PM, Jason Duell <jduell@mozilla.com> wrote:
How good are we at figuring out if a user is about to click a link (vs moving the mouse over it en route to other stuff)?  If we have a high % chance of guessing when a user is about to click on a link, we could also speculatively (and inexpensively) pre-open a TCP connnection for it.   I seem to recall some stats that it actually takes users a fraction of a second to focus precisely on a link?
        
roc then says:
We have API to easily find all the DOM elements within any given rectangle of the mouse cursor, so without too much trouble we could implement "if the mouse is near a link for more than a given amount of time, try preconnecting it".

..

The layout API in question is nsLayoutUtils::GetFramesForArea .. the necko api is io-service::speculativeConnect from bug 723628

Updated

7 years ago
Keywords: privacy-review-needed
Whiteboard: [Snappy:P2]
Whiteboard: [Snappy:P2] → [Snappy:P2][http-conn]
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881804
You need to log in before you can comment on or make changes to this bug.