Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Text doesn't appear on matrix.itasoftware.com

RESOLVED FIXED in Firefox 14

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Margaret, Assigned: luke)

Tracking

({regression})

Trunk
mozilla14
regression
Points:
---

Firefox Tracking Flags

(firefox14+ verified)

Details

(Whiteboard: [qa+], URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 607653 [details]
screenshot

I haven't looked into this closely to see what styles they're using, but a lot of the text around the form fields on matrix.itasoftware.com is not visible. Screenshot attached.

It works in the latest Aurora, but busted in Nightly.

Comment 1

5 years ago
Regression window(m-c),
Works:
http://hg.mozilla.org/mozilla-central/rev/ee56787a20fb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120316 Firefox/14.0a1 ID:20120316025529
Fails:
http://hg.mozilla.org/mozilla-central/rev/7f540f758671
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120316 Firefox/14.0a1 ID:20120316054431
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ee56787a20fb&tochange=7f540f758671


Regression window(m-i),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b752b0c0dc02
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120315 Firefox/14.0a1 ID:20120315100728
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/8f3b804118ef
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120315 Firefox/14.0a1 ID:20120315102728
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b752b0c0dc02&tochange=8f3b804118ef

Triggered by: Bug 730497
Blocks: 730497
Keywords: regression
OS: Mac OS X → All

Comment 2

5 years ago
It's not styles.  The text is not present in the DOM either.

All that stuff seems to be script-generated, and they're running into some sort of scripting issue.  E.g. see the "undefined" next to the dropdown with 1--9 in it...
No longer blocks: 730497
Keywords: qawanted, regressionwindow-wanted
OS: All → Mac OS X

Updated

5 years ago
Assignee: nobody → general
Blocks: 730497
tracking-firefox14: --- → ?
Component: General → JavaScript Engine
Keywords: qawanted, regressionwindow-wanted
OS: Mac OS X → All
QA Contact: general → general
Hardware: x86 → All
(Assignee)

Updated

5 years ago
No longer blocks: 730497
(Assignee)

Updated

5 years ago
Assignee: general → luke
Blocks: 733950
(Assignee)

Comment 3

5 years ago
Created attachment 607779 [details] [diff] [review]
fix and test
Attachment #607779 - Flags: review?(dvander)
(Assignee)

Comment 4

5 years ago
The bug was that arguments["i"] needs to return arguments[i] (for integers i) and the patch failed to do that when the arguments object had been optimized away (NormalArgumentsObject::optimizedGetElem).

Thanks for reporting Margaret!
Attachment #607779 - Flags: review?(dvander) → review+
(Reporter)

Comment 5

5 years ago
(In reply to Luke Wagner [:luke] from comment #4)

> Thanks for reporting Margaret!

Thanks for the super quick fix!
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/25cd2846cf90
(Assignee)

Updated

5 years ago
Target Milestone: --- → mozilla14
https://hg.mozilla.org/mozilla-central/rev/25cd2846cf90
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox14: --- → fixed
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 738083
tracking-firefox14: ? → +

Updated

5 years ago
Duplicate of this bug: 738229
Verified that text is properly displayed on:
http://matrix.itasoftware.com/
http://gs.statcounter.com/

Verified using Firefox 14 beta 8 on Windows XP, Mac OS X 10.6 and on Ubuntu 12.04:

Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0
status-firefox14: fixed → verified
Whiteboard: [qa+]
You need to log in before you can comment on or make changes to this bug.