Last Comment Bug 737597 - IonMonkey: Assertion failure: TODO: implement bigger offsets :(, at ion/arm/MacroAssembler-arm.cpp:804
: IonMonkey: Assertion failure: TODO: implement bigger offsets :(, at ion/arm/M...
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: ARM Linux
: -- major (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: langfuzz IonFuzz
  Show dependency treegraph
 
Reported: 2012-03-20 13:04 PDT by Christian Holler (:decoder)
Modified: 2012-06-11 13:13 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Christian Holler (:decoder) 2012-03-20 13:04:19 PDT
The following testcase asserts on ionmonkey revision e96d5b1f47b8 (run with --ion -n -m --ion-eager):


test();
function test() {
  var a = []; 
  a[.8e6 ]='foo'; 
}
Comment 1 Christian Holler (:decoder) 2012-03-20 13:13:31 PDT
ARM only, Ccing mjrosenb.
Comment 2 Christian Holler (:decoder) 2012-04-17 13:01:03 PDT
Can't reproduce this anymore. Martin, is this fixed/implemented now?
Comment 3 Marty Rosenberg [:mjrosenb] 2012-05-15 15:41:46 PDT
I haven't done anything to fix this, but it is a simple, decently low priority fix
Comment 4 Marty Rosenberg [:mjrosenb] 2012-06-11 13:13:58 PDT
this is is most definitely fixed now.
http://hg.mozilla.org/projects/ionmonkey/rev/9e1ad66c4e85
removed the assertion altogether.

Note You need to log in before you can comment on or make changes to this bug.