Closed Bug 737631 Opened 8 years ago Closed 8 years ago

clean up mozconfig whitelists

Categories

(Release Engineering :: General, defect, P2)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: catlee, Assigned: catlee)

Details

(Whiteboard: [release][mozconfig])

Attachments

(3 files)

release sanity warned about a lot of differences in the mozconfigs for 12.0b1. let's get those cleaned up
these things are enabled on nightly only, and that's ok
Attachment #608022 - Flags: review?(rail)
this updates the nightly mozconfigs for android to use the correct sdk. this could affect test results, but better to know now, since our release builds are built with this sdk.

the changes to linux32/64 are noops, just rearranging things to make release_sanity happy
Attachment #608023 - Flags: review?(aki)
Attachment #608023 - Flags: review?(aki) → review+
Attachment #608022 - Flags: review?(rail) → review+
Comment on attachment 608023 [details] [diff] [review]
clean up mozilla-beta mozconfigs

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: sad release engineers
Testing completed (on m-c, etc.): QA testing of beta builds, try builds
Risk to taking this patch (and alternatives if risky): breaks per-checkin beta tests
String changes made by this patch: None
Attachment #608023 - Flags: approval-mozilla-beta?
Comment on attachment 608023 [details] [diff] [review]
clean up mozilla-beta mozconfigs

[Triage Comment]
Approved for Beta 11.
Attachment #608023 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Alex Keybl [:akeybl] from comment #4)
> Approved for Beta 11.

s/11/12/
Attachment #608022 - Flags: checked-in+
Attachment #608023 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
should be a noop; just rearranging things so that flags appear in the same order in each file
Attachment #609292 - Flags: review?
Attachment #609292 - Flags: review? → review?(ted.mielczarek)
Comment on attachment 609292 [details] [diff] [review]
clean up mozilla-aurora mozconfigs

I want to land this on inbound and aurora. It's already landed on beta.
Attachment #609292 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 609292 [details] [diff] [review]
clean up mozilla-aurora mozconfigs

landed on inbound
Attachment #609292 - Flags: checked-in+
(In reply to Chris AtLee [:catlee] from comment #8)
> Comment on attachment 609292 [details] [diff] [review]
> clean up mozilla-aurora mozconfigs
> 
> landed on inbound

https://hg.mozilla.org/mozilla-central/rev/18801aa145f0
Comment on attachment 609292 [details] [diff] [review]
clean up mozilla-aurora mozconfigs

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: sad release engineers after the next aurora -> beta merge
Testing completed (on m-c, etc.): m-i, m-c, m-b
Risk to taking this patch (and alternatives if risky): it's functionally a noop
String changes made by this patch: none
Attachment #609292 - Flags: approval-mozilla-aurora?
Attachment #609292 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.