Last Comment Bug 737760 - IE Test Drive Irish Spring Demo Error "Canvas Is Undefined" because it relies on the global scope polluter in standards mode
: IE Test Drive Irish Spring Demo Error "Canvas Is Undefined" because it relies...
Status: RESOLVED DUPLICATE of bug 622491
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://ie.microsoft.com/testdrive/per...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 23:12 PDT by Leman Bennett [Omega]
Modified: 2012-03-20 23:50 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Leman Bennett [Omega] 2012-03-20 23:12:59 PDT
This is probably a dupe by now. But I'll file anyway.

The newest Microsoft HTML magic marketing demo "that only runs well in IE" named Irish Spring throws an error in Console:

canvas is not defined @ http://ie.microsoft.com/testdrive/performance/irishspring/setup.js:24

The canvas does not display. This demo works across all recent browsers except for Firefox versions.
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-03-20 23:37:48 PDT
I don't think this is a dup, fwiw.

This demo is relying on the global scope polluter in standards mode.

Maybe we should just give up on pushing back on that, since it's clear neither IE nor WebKit are willing to try to move the web forward here, and neither is the spec editor.  :(
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-03-20 23:50:26 PDT

*** This bug has been marked as a duplicate of bug 622491 ***

Note You need to log in before you can comment on or make changes to this bug.