The default bug view has changed. See this FAQ.

hg changelog and manifest updates are becoming visible to the hgweb server before updates to the file log

RESOLVED WORKSFORME

Status

Developer Services
General
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Ehsan, Assigned: bkero)

Tracking

Details

(Reporter)

Description

5 years ago
I am getting consistent repository corruptions when I try to pull from mozilla-central.  I filed this as a bug with Mercurial, but the developers there believe that this is being caused by us running a script on the server side which causes the changelog and manifest updates to be exposed to the hgweb server before the updates to the file log, which makes pulling fail if you happen to pull after the changelog and manifest have been updated but before the file log updates are visible.

I'm filing this bug for investigation of this problem on our side.  The hg bug is http://mercurial.selenic.com/bts/issue3324.

Updated

5 years ago
Assignee: server-ops → bkero
(Assignee)

Comment 1

5 years ago
After looking at the mercurial bug linked in here, they seem to have fixed this issue.  An update of Mercurial should solve this problem.
Blocks: 741353
(Reporter)

Comment 2

5 years ago
I thought that the mercurial folks believed that this is a bug on our side?
(Assignee)

Comment 3

5 years ago
The last comment on the bug is:


"This was fixed in http://selenic.com/hg/rev/5d75eb8568d1 , probably by mistake.", which leads me to believe that it was a problem on their side that got fixed.  Do you not agree?
(Reporter)

Comment 4

5 years ago
(In reply to comment #3)
> The last comment on the bug is:
> 
> "This was fixed in http://selenic.com/hg/rev/5d75eb8568d1 , probably by
> mistake.", which leads me to believe that it was a problem on their side that
> got fixed.  Do you not agree?

That is not the same bug (it was not filed by me).  I don't know if the original bug is still accessible somewhere...

Updated

5 years ago
Component: Server Operations → Server Operations: Developer Services
QA Contact: phong → shyam
Ehsan, still an issue?
(Reporter)

Comment 6

5 years ago
(In reply to comment #5)
> Ehsan, still an issue?

I do get corrupted repositories from time to time, yes.  But this happens much less frequently these days.
My hg <-> git mirror gets this corruption a few times per month. It's pretty bad that poorly timed hg pulls can corrupt a user's repository -- can we look in to this?

Why mercurial would allow a bad pull to corrupt your repository is another issue...
(Assignee)

Comment 8

4 years ago
Mercurial was not designed to be served over NFS. However they've been very accommodating in terms of accepting problems we run into that might have a root cause of hosting a repository on an NFS share.

My hope is that this is a race condition that will go away as we move to using local storage for hg web heads.
(Assignee)

Comment 9

4 years ago
@ehsan Could you find the bug you have with mercurial so we can figure out if this issue still exists? The bug number you reference earlier seems to have been fixed.
(Assignee)

Updated

4 years ago
No longer blocks: 741353
(Reporter)

Comment 10

4 years ago
(In reply to comment #9)
> @ehsan Could you find the bug you have with mercurial so we can figure out if
> this issue still exists? The bug number you reference earlier seems to have
> been fixed.

IIRC Mercurial changed their issue management software after I filed that issue, so I'm not sure if the old bug is still accessible anywhere (I don't have a working link to it any more.)  But if we deploy a new mercurial on the server, I can just increase the frequency of my scripts and see if the issue starts to happen again.  (FWIW I have not seen it for a while now)
My money is on this going away after moving off NFS.
Here's the original bug Ehsan filed, in the new bug tracker:

http://bz.selenic.com/show_bug.cgi?id=3325
(Reporter)

Updated

4 years ago
Blocks: 929335

Updated

3 years ago
Blocks: 934879
(Assignee)

Comment 13

3 years ago
Is this ever seen anymore? We're thinking this got solved from the NFS migration, but we'd like some confirmation.
Flags: needinfo?(ehsan)
(Reporter)

Comment 14

3 years ago
(In reply to Ben Kero [:bkero] from comment #13)
> Is this ever seen anymore? We're thinking this got solved from the NFS
> migration, but we'd like some confirmation.

I have long stopped maintaining my git mirror, so I haven't seen it recently, but that's because I have not been looking.  :-)
Flags: needinfo?(ehsan)
My agents doing automatic mirroring haven't seen any issues lately.

Let's call this resolved until proven otherwise.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.