No referer sent when flash request a file to server

RESOLVED DUPLICATE of bug 410904

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 410904
6 years ago
6 years ago

People

(Reporter: NaTong, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

The server block hotlinking file by check the referer.

When adobe flash request a file (such as image) to the server, Firefox 3.6.x and 10.0.x not sent the referer. But IE 8 and 9  did very well.


Actual results:

When adobe flash request a file (such as image) to the server, Firefox 3.6.x and 10.0.x not sent the referer. But IE 8 and 9  did very well.


Expected results:

Firefox should sent the referer to the server when flash request a file.
This will be fixed in Firefox 13
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410904
You need to log in before you can comment on or make changes to this bug.