Closed Bug 73818 Opened 24 years ago Closed 19 years ago

[FIXr]<BASE HREF="foo"> doesn't apply to forms

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla1.8beta4

People

(Reporter: brentdax1, Assigned: bzbarsky)

Details

(Keywords: fixed1.8)

Attachments

(1 file)

When submitting a form, the HREF parameter of the BASE tag is ignored.  This is
a problem on some CGI, where they use PATH_INFO to tell them what to do. 
PATH_INFO can become weird because of this.  I'm not sure what the HTML spec
says is the proper thing to do, but both Internet Explorer and Opera seem to
honor the BASE tag in form submissions.
worksforme, linux build 2001-03-28-08.  The BASE HREF is taken into account. 
Could you point to a URL or testcase where this fails?
Marking WORKSFORME due to inability to reproduce and lack of testcase. Reopen
when/if this reoccurs.
Status: UNCONFIRMED → RESOLVED
Closed: 24 years ago
Resolution: --- → WORKSFORME
verifying, tried to test PATH_INFO for a page with <BASE href="someaddress"> and
on all browsers PATH_INFO didnt show anything...
Status: RESOLVED → VERIFIED
how to reproduce: use invalid html!
(this "bug" works on all OSes; somebody who can please change that)

it seems to be an overall gecko bug:

Firefox 0.9.3/Win
Netscape 7.1/Win
FF1.0.3/debian
Epiphany 1.6.4/debian

base href ignored

IE 6/Win
Opera 7.11/Win
Konqueror 3.3.2/debian

works fine


on a BB someone replied it worked for him with Firefox 1.0.6

----
I set up a demo page for everybody to verify - and it worked fine there!
So I digged further into this and found out

the error occurs 
- with text before the opening <html> tag
AND
- the form tag placed between <table><tr> (see source at attached location)

repair one of these irregulations in your code, and all will work well!


http://www.ebiz-consult.de/_bugzilla/subdir/outpost.php
Reopening.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
Attached patch Proposed patchSplinter Review
Attachment #192715 - Flags: superreview?(jst)
Attachment #192715 - Flags: review?(mrbkap)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 192715 [details] [diff] [review]
Proposed patch

r=me
Attachment #192715 - Flags: review?(mrbkap) → review+
Comment on attachment 192715 [details] [diff] [review]
Proposed patch

sr=jst
Attachment #192715 - Flags: superreview?(jst) → superreview+
Comment on attachment 192715 [details] [diff] [review]
Proposed patch

I think this is worth doing for 1.8.  Very safe fix.
Attachment #192715 - Flags: approval1.8b4?
Assignee: rods → bzbarsky
OS: Windows 2000 → All
Priority: -- → P2
Hardware: PC → All
Summary: &lt;BASE HREF="foo"&gt; doesn't apply to forms → [FIXr]&lt;BASE HREF="foo"&gt; doesn't apply to forms
Target Milestone: --- → mozilla1.8beta4
Attachment #192715 - Flags: approval1.8b4? → approval1.8b4+
Keywords: fixed1.8
Fixed.
Status: NEW → RESOLVED
Closed: 24 years ago19 years ago
Resolution: --- → FIXED
Verifying fixed for mac Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.8b4) Gecko/20050908 Firefox/1.4
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: