Last Comment Bug 738287 - frequent browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_main.js | Test timed out
: frequent browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_m...
Status: RESOLVED FIXED
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 438871 714712
  Show dependency treegraph
 
Reported: 2012-03-22 09:09 PDT by Marco Bonardo [::mak] (Away 6-20 Aug)
Modified: 2012-11-25 19:31 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1.0 (1.43 KB, patch)
2012-03-22 09:09 PDT, Marco Bonardo [::mak] (Away 6-20 Aug)
ttaubert: review+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-22 09:09:53 PDT
Created attachment 608353 [details] [diff] [review]
patch v1.0

I think the problem is it's not waiting for the addons manager async operation to complete, this should fix it, though I'm still trying to run the test locally to check that.
Comment 1 Treeherder Robot 2012-03-22 09:52:46 PDT
jmaher%mozilla.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=10281198&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test mochitest-other on 2012-03-22 08:48:31

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_main.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_main.js | Found a  after previous test timed out
Comment 2 Tim Taubert [:ttaubert] 2012-03-22 09:52:48 PDT
Comment on attachment 608353 [details] [diff] [review]
patch v1.0

Review of attachment 608353 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! We should probably at least run it locally or push it to try before landing it.
Comment 3 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-22 09:54:15 PDT
I was finally able to run it locally, I had to uninstall Adobe Reader though.
Comment 4 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-22 09:57:43 PDT
https://hg.mozilla.org/mozilla-central/rev/4c7b843406a2

let's see if this was the only problem.

Note You need to log in before you can comment on or make changes to this bug.