Last Comment Bug 738507 - Showing large pdf files in pdf.js ends up having the spinner in most of the pages
: Showing large pdf files in pdf.js ends up having the spinner in most of the p...
Status: RESOLVED FIXED
[testday-20121101]
:
Product: Firefox
Classification: Client Software
Component: PDF Viewer (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Brendan Dahl [:bdahl]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 17:31 PDT by Olli Pettay [:smaug]
Modified: 2012-11-01 15:13 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Olli Pettay [:smaug] 2012-03-22 17:31:35 PDT
I tried to open http://mozilla.pettay.fi/html.pdf (html spec printed to .pdf), and
pdf.js shows mostly just spinners in the pages. Some page may render for some time, 
but if you scroll away, and back, the spinner is often there again.
Comment 1 Mihaela Velimiroviciu (:mihaelav) 2012-06-22 07:17:02 PDT
this is reproducible on all platforms
Comment 2 Brendan Dahl [:bdahl] 2012-07-17 10:10:09 PDT
We changed around the rendering priority in the current nightly(17).  You can still get spinners if you scroll very quickly, but since the rendering of pages with low priority is paused it feels much snappier.  Try it out and let us know if we can close this.
Comment 3 Olli Pettay [:smaug] 2012-07-17 10:42:36 PDT
Much better. thanks.
Comment 4 Gabriela [:gaby2300] 2012-11-01 15:13:48 PDT
Verified fixed using Windows 7 and the latest Nightly.

Note You need to log in before you can comment on or make changes to this bug.