Closed Bug 738681 Opened 10 years ago Closed 9 years ago

WebGL is disabled or unavailable on FroYo

Categories

(Core :: Graphics: CanvasWebGL, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: xti, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot
Steps to reproduce:
1. Open Fennec
2. Browse to http://get.webgl.org/

Expected result:
The webgl content is displayed correctly (a cube will keep rotating smoothly)

Actual result:
WebGL content is missing (see screenshot).

In console this error occurs twice while loading the test page:
E/GeckoConsole(12499): [JavaScript Warning: "WebGL: Can't get a usable WebGL context" {file: "http://get.webgl.org/" line: 187}]
This issue it's reproducible on the latest Nightly (03/23), on Samsung Galaxy S, LG Optimus 2X and HTC Desire (all are running Android 2.2).
Component: General → Canvas: WebGL
Product: Fennec Native → Core
QA Contact: general → canvas.webgl
The issue is also reproducible on:
Firefox/15.0.1b2 - (07/17)
HTC Desire Z - Android (2.3.3)
I know our ARMv7+Android2.2 slaves run WebGL fine. I'm going to close this because I heavily suspect that this has since been fixed.

Please reopen if you have a device which still isn't giving webgl, but used to.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.