Installer - all-proxy.js is appended, not replaced

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: benc@chuang.net, Assigned: Sean Su)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Commercial build:
Win32 2001-03-28-09-Mtrunk

STEPS:
1- Using N6Setup.exe, select a proxy when installing.
2- Complete successful install.
3- Examine all-proxy.js

The file seems to have a set of prefs entries for each previous install, almost
like a log.

Bug 39015 describes the basic function of this feature, and from the reading, my
feeling is that the installer should over-write, rather than append an existing
all-proxy.js.
(Assignee)

Comment 1

17 years ago
but does it pick up the last settings set?  The installer does not have a parser 
to search/replace strings in a file.

What happens if you run and quit mozilla.exe? do you still see multiple 
settings, or just one?
Status: NEW → ASSIGNED
(Reporter)

Comment 2

17 years ago
I've been told that the prefs loader keeps only the last value for duplicate 
lines.

If all-proxy.js exists, then blow it away before writing the new values.
(Assignee)

Comment 3

17 years ago
over to david.
Assignee: ssu → dprice
Status: ASSIGNED → NEW

Updated

17 years ago
QA Contact: bugzilla → ktrina

Comment 4

17 years ago
taking all proxy related bugs
QA Contact: ktrina → gbush

Comment 5

17 years ago
adding Ben to proxy bugs as requested

Comment 6

16 years ago
Another example of some serious bustage:

While goofing around and installing mozilla on a friends computer, entered a
bogus hostname and no port value to see if it would failover to a direct connection.

The installer does run off the direct connection (b/c port==0), but then when
mozilla launches, it went deaf b/c it inhereted the port number of a previous
proxy install:

all-proxy.ja:

pref("network.proxy.http_port", 443);
pref("network.proxy.type", 1);
pref("network.proxy.http", "asdfasdf");
pref("network.proxy.type", 1);

Can't someone make a one-line change and blow the file away rather than append
the file? Totally easy, and easy to reproduce, for that matter.
Keywords: nsbeta1

Comment 7

16 years ago
nsbeta1+ per buffy traige
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla1.2alpha

Comment 8

16 years ago
minusing for buffy triage
Assignee: dprice → benc
Keywords: nsbeta1+ → nsbeta1-

Comment 9

15 years ago
-> defaults. I shouldn't be the owner.
Assignee: benc → ssu
QA Contact: gbush → bugzilla

Comment 10

14 years ago
I'm going to see if I can get a patch for this.
QA Contact: bugzilla → benc

Comment 11

14 years ago
-> --
Target Milestone: mozilla1.2alpha → ---

Comment 12

14 years ago
Here's the source of the problem, the function originally appeneded to all.js.

bug 39015 comment 10.

Comment 13

14 years ago
The problem is this line:

  if((fJSFile = fopen(szJSFile, "a+t")) != NULL)    

My c is very rusty, but all that needs to be done is to change it to create a
file instead of appending.

Comment 14

14 years ago
Created attachment 148052 [details] [diff] [review]
over-writes all-proxy.js, rather than appends

(I did not build this patch)

Updated

14 years ago
Attachment #148052 - Flags: review?(ssu0262)
(Assignee)

Updated

14 years ago
Attachment #148052 - Flags: review?(ssu0262) → review+
(Assignee)

Comment 15

14 years ago
Comment on attachment 148052 [details] [diff] [review]
over-writes all-proxy.js, rather than appends

r=ssu

Updated

14 years ago
Attachment #148052 - Flags: superreview?(dveditz)
Comment on attachment 148052 [details] [diff] [review]
over-writes all-proxy.js, rather than appends

sr=dveditz
Attachment #148052 - Flags: superreview?(dveditz) → superreview+
Product: Browser → Seamonkey
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.