Last Comment Bug 738761 - Remove nsIScriptTimeoutHandler::GetScriptVersion and pass JSVersion to nsIScriptContext::EvaluateString
: Remove nsIScriptTimeoutHandler::GetScriptVersion and pass JSVersion to nsIScr...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 695753
  Show dependency treegraph
 
Reported: 2012-03-23 12:53 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-03-30 05:35 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (8.08 KB, patch)
2012-03-23 12:53 PDT, :Ms2ger (⌚ UTC+1/+2)
jst: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-03-23 12:53:48 PDT
Created attachment 608832 [details] [diff] [review]
Patch v1
Comment 1 Johnny Stenback (:jst, jst@mozilla.com) 2012-03-27 14:49:48 PDT
Comment on attachment 608832 [details] [diff] [review]
Patch v1

- In dom/base/nsIScriptTimeoutHandler.h:

-
-  // Get the language version for this timeout.
-  virtual PRUint32 GetScriptVersion() = 0;

Bump the uuid for this interface since you're removing methods from it.

r=jst with that.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-03-30 05:35:42 PDT
https://hg.mozilla.org/mozilla-central/rev/167d10d80590

Note You need to log in before you can comment on or make changes to this bug.