Last Comment Bug 738908 - calculator buttons on ecalc.com don't work
: calculator buttons on ecalc.com don't work
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
http://www.ecalc.com/
Depends on:
Blocks: 730139
  Show dependency treegraph
 
Reported: 2012-03-24 03:53 PDT by Bram Speeckaert
Modified: 2012-05-01 10:40 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
-


Attachments

Description Bram Speeckaert 2012-03-24 03:53:23 PDT
The calculator buttons on ecalc.com appear to have stopped working since the 2012-03-10 Nightly build. Since this was before the migration, I'm assuming the current Aurora builds are affected as well.

Works:
2012-03-09
Doesn't work:
2012-03-10

Tested on:
Windows 7 64-bit with 32-bit builds
Linux 64-bit
Comment 1 Alice0775 White 2012-03-24 04:17:54 PDT
Confirmed

Error: let is a reserved identifier
Source file: http://www.ecalc.com/js/members/tracking2.js
Line: 1, Column: 20244

Triggered by;
6d139ebc0f43	Adam — Make "let" a reserved word for Web scripts. Bug 730139, r=jorendorff.
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-03-24 17:12:58 PDT
The script has a variable named "let" (undeclared variable at that) that it uses for letters...

The site is also broken in a Safari nightly (but not in shipping Safari), as expected.

That experiment didn't take long.... :(

Requesting tracking for this, since we'll have to decide whether to leave the patch in when 13 ships or not.
Comment 3 Tom Schuster [:evilpie] 2012-04-28 10:45:24 PDT
So was this backed out already?
Comment 4 Jeff Walden [:Waldo] (remove +bmo to email) 2012-04-28 15:37:12 PDT
The backout changeset seems to be everywhere, so I think we're good:

https://hg.mozilla.org/releases/mozilla-aurora/rev/d8a908424870
https://hg.mozilla.org/releases/mozilla-beta/rev/d4aa73deb585
https://hg.mozilla.org/mozilla-central/rev/d8a908424870

Note You need to log in before you can comment on or make changes to this bug.