Last Comment Bug 738919 - [Azure] [Quartz] ctx.mozDash does not support odd number of items
: [Azure] [Quartz] ctx.mozDash does not support odd number of items
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks: 715768
  Show dependency treegraph
 
Reported: 2012-03-24 06:49 PDT by Yury Delendik (:yury)
Modified: 2012-05-20 13:41 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Minimal test case for odd mozDash (298 bytes, text/html)
2012-03-24 06:49 PDT, Yury Delendik (:yury)
no flags Details
Accept dash arrays of length >0 (1.38 KB, patch)
2012-03-26 15:08 PDT, Jeff Muizelaar [:jrmuizel]
matt.woodrow: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
Reftest that catches this (1.25 KB, patch)
2012-03-26 19:56 PDT, Jeff Muizelaar [:jrmuizel]
matt.woodrow: review+
Details | Diff | Splinter Review

Description Yury Delendik (:yury) 2012-03-24 06:49:46 PDT
Created attachment 608992 [details]
Minimal test case for odd mozDash

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20120323 Firefox/14.0a1

The even number items in the dash works, but not odd. Works in FF11.

(see https://github.com/mozilla/pdf.js/issues/1398)
Comment 1 Josh Matthews [:jdm] (away until 9/3) 2012-03-24 08:17:34 PDT
Disabling gfx.canvas.azure.enabled fixes this problem.
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-03-26 15:08:30 PDT
Created attachment 609505 [details] [diff] [review]
Accept dash arrays of length >0

I copied the skia code here and took it's bug. This fixes the CG version and puts a note into the skia code.
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-03-26 19:55:16 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3f9b7201c29d
Comment 4 Jeff Muizelaar [:jrmuizel] 2012-03-26 19:56:46 PDT
Created attachment 609591 [details] [diff] [review]
Reftest that catches this
Comment 5 Ed Morley [:emorley] 2012-03-27 05:16:21 PDT
https://hg.mozilla.org/mozilla-central/rev/3f9b7201c29d
Comment 6 Ed Morley [:emorley] 2012-03-28 14:22:45 PDT
https://hg.mozilla.org/mozilla-central/rev/f2e02f954e78
Comment 7 Jeff Muizelaar [:jrmuizel] 2012-04-10 15:18:59 PDT
Comment on attachment 609505 [details] [diff] [review]
Accept dash arrays of length >0

[Approval Request Comment]
Regression caused by (bug #): 692879
User impact if declined: Sometimes we'll dash incorrectly. This is most likely to show up with pdf.js because it requires using the mozDash addition to canvas which is relatively new.
Testing completed (on m-c, etc.): Tested on m-c
Risk to taking this patch (and alternatives if risky): Very low.
String changes made by this patch: none

Note You need to log in before you can comment on or make changes to this bug.