Last Comment Bug 739008 - [SeaMonkey] "test_sts_privatebrowsing.html | [SimpleTest.finish()] No checks actually run"
: [SeaMonkey] "test_sts_privatebrowsing.html | [SimpleTest.finish()] No checks ...
Status: VERIFIED FIXED
[perma-orange]
: regression
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: P2 major (vote)
: mozilla14
Assigned To: Serge Gautherie (:sgautherie)
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: SmTestFail 557598 735805
  Show dependency treegraph
 
Reported: 2012-03-24 18:58 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-04-01 12:29 PDT (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
affected
verified
affected


Attachments
(Av1) Fix and improve test_sts_privatebrowsing.html [Checked in: See comment 6] (8.56 KB, patch)
2012-03-24 22:31 PDT, Serge Gautherie (:sgautherie)
mozbugs: review+
Details | Diff | Review
(Cv1-a13) Fix and improve test_sts_privatebrowsing.html [Checkin: Comment 10] (8.60 KB, patch)
2012-03-27 02:17 PDT, Serge Gautherie (:sgautherie)
no flags Details | Diff | Review

Description Serge Gautherie (:sgautherie) 2012-03-24 18:58:18 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332625911.1332627901.23122.gz
WINNT 5.2 comm-central-trunk debug test mochitests-5/5 on 2012/03/24 14:51:51
s: cn-sea-qm-win2k3-01
{
1748 INFO TEST-START | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html

++DOMWINDOW == 152 (0C745B20) [serial = 1668] [outer = 06FBBF48]

1749 ERROR TEST-UNEXPECTED-FAIL | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | [SimpleTest.finish()] No checks actually run. (You need to call ok(), is(), or similar functions at least once.  Make sure you use SimpleTest.waitForExplicitFinish() if you need it.)

1750 INFO TEST-END | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | finished in 757ms
}
Comment 1 Serge Gautherie (:sgautherie) 2012-03-24 20:59:53 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332628571.1332629573.25913.gz
OS X 10.6 comm-central-trunk debug test mochitests-5/5 on 2012/03/24 15:36:11

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332646211.1332647224.24417.gz
WINNT 5.2 comm-central-trunk debug test mochitests-5/5 on 2012/03/24 20:30:11
Comment 2 Serge Gautherie (:sgautherie) 2012-03-24 22:31:12 PDT
Created attachment 609075 [details] [diff] [review]
(Av1) Fix and improve test_sts_privatebrowsing.html
[Checked in: See comment 6]
Comment 3 Sid Stamm [:geekboy or :sstamm] 2012-03-26 10:07:58 PDT
Comment on attachment 609075 [details] [diff] [review]
(Av1) Fix and improve test_sts_privatebrowsing.html
[Checked in: See comment 6]

Review of attachment 609075 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.  Would it make sense to also convert this test to use SpecialPowers?
Comment 4 Serge Gautherie (:sgautherie) 2012-03-26 14:08:35 PDT
Comment on attachment 609075 [details] [diff] [review]
(Av1) Fix and improve test_sts_privatebrowsing.html
[Checked in: See comment 6]

https://hg.mozilla.org/mozilla-central/rev/66ed24196754


(In reply to Sid Stamm [:geekboy] from comment #3)
> Would it make sense to also convert this test to use SpecialPowers?

Probably, but I don't want to get into that in this bug.
Comment 5 Matt Brubeck (:mbrubeck) 2012-03-26 14:40:16 PDT
Sorry, I had to back this out:
https://hg.mozilla.org/mozilla-central/rev/82a5a9a0e12b

because it turned test_sts_privatebrowsing.html perma-orange with "tests.shift is not a function":
https://tbpl.mozilla.org/php/getParsedLog.php?id=10381117&tree=Firefox
Comment 6 Serge Gautherie (:sgautherie) 2012-03-27 01:37:59 PDT
Comment on attachment 609075 [details] [diff] [review]
(Av1) Fix and improve test_sts_privatebrowsing.html
[Checked in: See comment 6]

https://hg.mozilla.org/mozilla-central/rev/360c61ec152a
(Av1a) Fix and improve test_sts_privatebrowsing.html
(Syntax error fix in FF case.)
+
https://hg.mozilla.org/mozilla-central/rev/5adbca606d51
(Bv1) Fix patch Av1a
(Missing assignment in FF case.)


(In reply to Matt Brubeck (:mbrubeck) from comment #5)
> Sorry, I had to back this out:

I apologize: I missed to test FF case :-<
Comment 7 Serge Gautherie (:sgautherie) 2012-03-27 01:46:26 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=10386791&tree=Firefox&full=1
Rev3 Fedora 12x64 mozilla-central opt test mochitests-5/5 on 2012-03-26 17:20:01 PDT for push 5adbca606d51
{
1762 INFO TEST-START | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html

1764 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | Not in private browsing mode

1775 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | Cleaning up STS data

1778 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | Entering private browsing mode ...
1779 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | ... done

1792 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | Exiting private browsing mode ...
1793 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | ... done

1805 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | Cleaning up STS data

1807 INFO TEST-END | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | finished in 1137ms
}
Comment 8 Serge Gautherie (:sgautherie) 2012-03-27 01:55:20 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332816184.1332817312.10936.gz&fulltext=1
OS X 10.6 comm-central-trunk debug test mochitests-5/5 on 2012/03/26 19:43:04
{
1759 INFO TEST-START | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html
1760 INFO TEST-KNOWN-FAIL | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | PB service is not available, will skip dependent tests
1761 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | State of example.com: false
1762 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | Not in private browsing mode

1772 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | DONE WITH ROUND plain
1773 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | Cleaning up STS data
1774 INFO TEST-INFO | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | State of example.com: false
1775 INFO TEST-END | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | finished in 1825ms
}

V.Fixed
Comment 9 Serge Gautherie (:sgautherie) 2012-03-27 02:17:37 PDT
Created attachment 609661 [details] [diff] [review]
(Cv1-a13) Fix and improve test_sts_privatebrowsing.html [Checkin: Comment 10]

Cv1-a13 = Av1a + Bv1,
with
(In reply to Alex Keybl [:akeybl] from bug 735805 comment #77)
> (the above includes blanket approval for the other test fixes for Aurora 13)

NB: On Beta/12, it will need a manual "s/nsIPrefBranch/nsIPrefBranch2/".
Comment 10 Jens Hatlak (:InvisibleSmiley) 2012-03-31 04:28:56 PDT
Comment on attachment 609661 [details] [diff] [review]
(Cv1-a13) Fix and improve test_sts_privatebrowsing.html [Checkin: Comment 10]

http://hg.mozilla.org/releases/mozilla-aurora/rev/3ae20fbe49e6
Comment 11 Serge Gautherie (:sgautherie) 2012-04-01 12:29:38 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1333214246.1333215253.19057.gz&fulltext=1
OS X 10.6 comm-aurora debug test mochitests-5/5 on 2012/03/31 10:17:26
{
1746 INFO TEST-KNOWN-FAIL | /tests/security/ssl/stricttransportsecurity/test_sts_privatebrowsing.html | PB service is not available, will skip dependent tests
[...]
}

firefox13: verified.

Note You need to log in before you can comment on or make changes to this bug.