Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Bookmark edit panels do not expand correctly

RESOLVED FIXED in seamonkey2.11

Status

SeaMonkey
Bookmarks & History
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
seamonkey2.11
regression

SeaMonkey Tracking Flags

(seamonkey2.9+ fixed, seamonkey2.10 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
The expanders in the star popup and bookmark manager edit panel do not properly resize the container to accommodate the extra controls.
(Assignee)

Comment 1

5 years ago
Created attachment 609105 [details] [diff] [review]
Proposed patch [Checkin: Comments 3 and 7]

[Approval Request Comment]
Regression caused by (bug #): 605786
User impact if declined: Unable to use parts of the UI
Testing completed (on m-c, etc.): Almost got r=InvisibleSmiley in bug 733687
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #609105 - Flags: review?(jh)
Attachment #609105 - Flags: approval-comm-aurora?
Comment on attachment 609105 [details] [diff] [review]
Proposed patch [Checkin: Comments 3 and 7]

Confirming regression fix using local Aurora build with the patch.
Attachment #609105 - Flags: review?(jh)
Attachment #609105 - Flags: review+
Attachment #609105 - Flags: approval-comm-aurora?
Attachment #609105 - Flags: approval-comm-aurora+
(Assignee)

Comment 3

5 years ago
Pushed changeset 7ab228e905a7 to mozilla-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.11: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [transplant to comm-aurora]
Target Milestone: --- → seamonkey2.11
(In reply to neil@parkwaycc.co.uk from comment #3)
> Pushed changeset 7ab228e905a7 to mozilla-central.
                                   ^^^^^^^
Hardly. ;-) You can make everyone's life easier by noting the URL instead, like the rest of us does.
(Assignee)

Comment 5

5 years ago
(In reply to Jens Hatlak from comment #4)
> (In reply to comment #3)
> > Pushed changeset 7ab228e905a7 to mozilla-central.
>                                    ^^^^^^^
> Hardly. ;-) You can make everyone's life easier by noting the URL instead,
> like the rest of us does.

Oops. But how else will I copy all three changesets at once from the pushlog?
(In reply to neil@parkwaycc.co.uk from comment #5)
> Oops. But how else will I copy all three changesets at once from the pushlog?

Here's what I do:
1. Middle-click the links of all changesets I want to note so they'll open in new tabs.
2. Verify once more that I actually pushed the right stuff with the right bug numbers/descriptions.
3. Middle-click the bug links from the summaries. With tabs opening relative, I get an alternating list of tabs, like [changeset 1][bug for changeset 1][...].
4. Copy the contents of the location bar of each changeset page, go one tab to the left, do my thing [1], rinse, repeat.

[1] Scroll down, remember last comment number (+1), scroll up, middle-click attachment's "Details" link, paste changeset URL in comment box, click "(edit details)" link, append " [Checkin: Comment x]", where x is what I remembered (or if memory fails me, go back to the other tab). Close tabs as necessary.
Comment on attachment 609105 [details] [diff] [review]
Proposed patch [Checkin: Comments 3 and 7]

http://hg.mozilla.org/releases/comm-aurora/rev/dcc865d68be7
Attachment #609105 - Attachment description: Proposed patch → Proposed patch [Checkin: Comments 3 and 7]
status-seamonkey2.10: affected → fixed
status-seamonkey2.11: fixed → ---
Keywords: checkin-needed
Whiteboard: [transplant to comm-aurora]
Bah, since bug 605786 landed on beta before the uplift, this one should have been landed on beta, too. Now this bug is in SM 2.9. :-(

Callek, if by any chance we need to have a 2.9.1, please let us include this bugfix (see comment 1 for risk assertion).
status-seamonkey2.9: --- → affected
tracking-seamonkey2.9: --- → ?
Comment on attachment 609105 [details] [diff] [review]
Proposed patch [Checkin: Comments 3 and 7]

[Triage Comment]
Yea lets take this for 2.9.1
Attachment #609105 - Flags: approval-comm-release+
http://hg.mozilla.org/releases/comm-release/rev/c475bdfedc35
status-seamonkey2.9: affected → fixed
tracking-seamonkey2.9: ? → +
You need to log in before you can comment on or make changes to this bug.