Last Comment Bug 739136 - segfault in B2G on desktop
: segfault in B2G on desktop
Status: RESOLVED DUPLICATE of bug 739452
:
Product: Firefox OS
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 23:12 PDT by David Flanagan [:djf]
Modified: 2012-03-28 10:16 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description David Flanagan [:djf] 2012-03-25 23:12:32 PDT
B2G crashes for me tonight on MacOS with the trace below.  This looks like it is a different stack trace than https://bugzilla.mozilla.org/show_bug.cgi?id=739123


djf$ hg bisect -b
The first bad revision is:
changeset:   90273:7f87b434f7c6
 


Thread 3 Crashed:  Gecko_IOThread
0   XUL                           	0x0000000101f19548 mozilla::ipc::RilClient::OpenSocket() + 136 (Ril.cpp:179)
1   XUL                           	0x0000000101f19801 mozilla::ipc::RilReconnectTask::Run() + 17 (Ril.cpp:123)
2   XUL                           	0x0000000101f8f823 MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) + 147 (message_loop.cc:319)
3   XUL                           	0x0000000101f8fa3e MessageLoop::DoDelayedWork(base::Time*) + 302 (message_loop.cc:453)
4   XUL                           	0x0000000101f99a5f base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) + 159 (message_pump_libevent.cc:315)
5   XUL                           	0x0000000101f8f280 MessageLoop::Run() + 64 (message_loop.cc:487)
6   XUL                           	0x0000000101f94f73 base::Thread::ThreadMain() + 131 (thread.cc:159)
7   XUL                           	0x0000000101f9a0ea ThreadFunc(void*) + 10 (platform_thread_posix.cc:28)
8   libSystem.B.dylib             	0x00007fff8721cfd6 _pthread_start + 331
9   libSystem.B.dylib             	0x00007fff8721ce89 thread_start + 13
Comment 1 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-03-26 07:39:14 PDT
Happens on Linux as well.
Comment 2 David Flanagan [:djf] 2012-03-26 13:02:36 PDT
Workaround: Download this python code and run this before starting b2g:

% python fauxphone.py -i &

Code is here: https://gist.github.com/2205561

I'm not sure who wrote that code, but it works for me
Comment 3 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-03-26 13:09:29 PDT
(In reply to David Flanagan from comment #2) 
> I'm not sure who wrote that code, but it works for me

fwit, mrbkap wrote that.
Comment 4 Kyle Machulis [:qdot] 2012-03-28 10:16:21 PDT
Duplicate of bug 739452 (this one was filed first, but bug 739452 has more information and resolution chain.)

*** This bug has been marked as a duplicate of bug 739452 ***

Note You need to log in before you can comment on or make changes to this bug.