Incorrect fill arc path with canvas

RESOLVED FIXED

Status

()

Core
Canvas: 2D
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ekorobko, Unassigned)

Tracking

({regression, testcase})

11 Branch
x86_64
Windows 7
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 609250 [details]
canvas_arc_ff.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I try to fill a half of ring with canvas fill method


Actual results:

canvas ignores inside arc and fills a hals of whole circle


Expected results:

a half of ring should be filled. I tested with chrome 17 and IE9 and both of them work correctly. Sample HTML and screenshots are attached.
(Reporter)

Comment 1

6 years ago
Created attachment 609251 [details]
compare drawing FF/chome/IE
Attachment #609250 - Attachment mime type: text/plain → text/html

Comment 2

6 years ago
Regression window(m-c)
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/450e4d9ea2d5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 ID:20110625025936
Can reploduce:
http://hg.mozilla.org/mozilla-central/rev/48ad4ffc4230
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110625 Firefox/7.0a1 ID:20110625030821

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=450e4d9ea2d5&tochange=48ad4ffc4230

Regression window(m-i)
Cannot reproduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c65f1fb0449d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 ID:20110624094307
Can reploduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/46c3d095bc75
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 ID:20110624104626
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c65f1fb0449d&tochange=46c3d095bc75

Triggered by: Bug 651858
Blocks: 651858
Status: UNCONFIRMED → NEW
Component: Untriaged → Canvas: 2D
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: untriaged → canvas.2d
Keywords: testcase

Comment 3

6 years ago
Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/0aa393eef856
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1 ID:20120427033919
Good:
http://hg.mozilla.org/mozilla-central/rev/d871849ac3a3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1 ID:20120427045419
Fixed pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0aa393eef856&tochange=d871849ac3a3

Fixed window(m-c)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b7a03f6f1a3e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120426 Firefox/15.0a1 ID:20120426180721
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/add831dc812e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120426 Firefox/15.0a1 ID:20120426221218
Fixed pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b7a03f6f1a3e&tochange=add831dc812e

This seemed to be fixed by Bug 749467
Thanks Alice. Since this is fixed in FF13 and later, we don't need to do anything more here.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.